package/cryptsetup: disable tmpfiles.d for host build
authorJohn Keeping <john@metanate.com>
Fri, 7 May 2021 15:21:59 +0000 (16:21 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 8 May 2021 16:24:01 +0000 (18:24 +0200)
When building host-cryptsetup, if tmpfiles.d support is enabled then the
install step tries to install /usr/lib/tmpfiles.d/cryptsetup.conf
globally on the host system.

Even if the tmpfiles.d config were installed correctly in the host
directory, nothing would ever run these rules, so disable this feature
via configure.

Signed-off-by: John Keeping <john@metanate.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/cryptsetup/cryptsetup.mk

index 719885b59ca2208cd5cc128ad468c77510456869..cd5883d0b43c7a848cf40e474ae845677d7d4cf8 100644 (file)
@@ -43,7 +43,8 @@ HOST_CRYPTSETUP_DEPENDENCIES = \
 
 HOST_CRYPTSETUP_CONF_OPTS = --with-crypto_backend=openssl \
        --disable-kernel_crypto \
-       --enable-blkid
+       --enable-blkid \
+       --with-tmpfilesdir=no
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))