toolchain: check ARM EABI vs. EABIhf for external toolchains
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 17 Jul 2013 20:30:48 +0000 (22:30 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 17 Jul 2013 22:22:40 +0000 (00:22 +0200)
Following the introduction of the support of EABIhf as a second ARM
ABI, it is important to check whether the external toolchain provided
by the user actually uses the ABI that has been selected in the
Buildroot configuration. This commit introduces such a check by
looking at the 'Tag_ABI_VFP_args' tag of the architecture-specific
section of the ELF headers. This assumes that ELF is the binary format
used on ARM, which may not be the case on ARM noMMU systems (they use
the FLAT binary format), but Buildroot doesn't have support for such
systems at the moment.

Also ensure the correct CFLAGS are passed to the cross compiler for the
test, so the correct variant is used in case the toolchain is multilib.

[Peter: mention CFLAGS change]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/helpers.mk
toolchain/toolchain-external/ext-tool.mk

index 764c795d85ce311570f30fe4d7ad3b8f0bf1a330..4c988a5c9ac37669e10fda38d998ca8748c5a879 100644 (file)
@@ -279,10 +279,25 @@ check_uclibc = \
 #
 check_arm_abi = \
        __CROSS_CC=$(strip $1) ; \
+       __CROSS_READELF=$(strip $2) ; \
        EXT_TOOLCHAIN_TARGET=`LANG=C $${__CROSS_CC} -v 2>&1 | grep ^Target | cut -f2 -d ' '` ; \
        if ! echo $${EXT_TOOLCHAIN_TARGET} | grep -qE 'eabi(hf)?$$' ; then \
                echo "External toolchain uses the unsuported OABI" ; \
                exit 1 ; \
+       fi ; \
+       EXT_TOOLCHAIN_CRT1=`LANG=C $${__CROSS_CC} -print-file-name=crt1.o` ; \
+       if $${__CROSS_READELF} -A $${EXT_TOOLCHAIN_CRT1} | grep -q "Tag_ABI_VFP_args:" ; then \
+               EXT_TOOLCHAIN_ABI="eabihf" ; \
+       else \
+               EXT_TOOLCHAIN_ABI="eabi" ; \
+       fi ; \
+       if [ "$(BR2_ARM_EABI)" = "y" -a "$${EXT_TOOLCHAIN_ABI}" = "eabihf" ] ; then \
+               echo "Incorrect ABI setting: EABI selected, but toolchain uses EABIhf" ; \
+               exit 1 ; \
+       fi ; \
+       if [ "$(BR2_ARM_EABIHF)" = "y" -a "$${EXT_TOOLCHAIN_ABI}" = "eabi" ] ; then \
+               echo "Incorrect ABI setting: EABIhf selected, but toolchain uses EABI" ; \
+               exit 1 ; \
        fi
 
 #
index b9ae68f0a3a4401937c2781caed6a59087576d96..80e03b980816653dac72858e8b6603fb32be49a8 100644 (file)
@@ -125,6 +125,7 @@ endif
 TOOLCHAIN_EXTERNAL_CROSS=$(TOOLCHAIN_EXTERNAL_BIN)/$(TOOLCHAIN_EXTERNAL_PREFIX)-
 TOOLCHAIN_EXTERNAL_CC=$(TOOLCHAIN_EXTERNAL_CROSS)gcc
 TOOLCHAIN_EXTERNAL_CXX=$(TOOLCHAIN_EXTERNAL_CROSS)g++
+TOOLCHAIN_EXTERNAL_READELF=$(TOOLCHAIN_EXTERNAL_CROSS)readelf
 TOOLCHAIN_EXTERNAL_WRAPPER_ARGS = -DBR_SYSROOT='"$(STAGING_SUBDIR)"'
 
 ifeq ($(filter $(HOST_DIR)/%,$(TOOLCHAIN_EXTERNAL_BIN)),)
@@ -368,7 +369,9 @@ $(STAMP_DIR)/ext-toolchain-checked: $(TOOLCHAIN_EXTERNAL_DEPENDENCIES)
                exit 1 ; \
        fi ; \
        if test x$(BR2_arm) == x"y" ; then \
-               $(call check_arm_abi,$(TOOLCHAIN_EXTERNAL_CC)) ; \
+               $(call check_arm_abi,\
+                       "$(TOOLCHAIN_EXTERNAL_CC) $(TOOLCHAIN_EXTERNAL_CFLAGS)",\
+                       $(TOOLCHAIN_EXTERNAL_READELF)) ; \
        fi ; \
        if test x$(BR2_INSTALL_LIBSTDCPP) == x"y" ; then \
                $(call check_cplusplus,$(TOOLCHAIN_EXTERNAL_CXX)) ; \