package/netopeer2: add dependency to host-sysrepo
authorHeiko Thiery <heiko.thiery@gmail.com>
Sat, 6 Feb 2021 10:57:37 +0000 (11:57 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 11 Feb 2021 17:40:22 +0000 (18:40 +0100)
The sysrepoctl executable from the host-sysrepo package is used to
install YANG modules during installation. So add the dependency here.
Also make sure we use this executable by setting the make environment
variable SYSREPOCTL_EXECUTABLE. Otherwise a system wide installed
sysrepoctl would be used that is not what we want.

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/netopeer2/netopeer2.mk

index bc02e0dc9355d5ac175401bb97f33d88f0e6e10d..10a13dfda9de252ff108c57c6ebcba6f1e4146cf 100644 (file)
@@ -9,10 +9,12 @@ NETOPEER2_SITE = $(call github,CESNET,Netopeer2,v$(NETOPEER2_VERSION))
 NETOPEER2_DL_SUBDIR = netopeer2
 NETOPEER2_LICENSE = BSD-3-Clause
 NETOPEER2_LICENSE_FILES = LICENSE
-NETOPEER2_DEPENDENCIES = libnetconf2 libyang sysrepo
+NETOPEER2_DEPENDENCIES = libnetconf2 libyang sysrepo host-sysrepo
 
 NETOPEER2_CONF_OPTS = -DBUILD_CLI=$(if $(BR2_PACKAGE_NETOPEER2_CLI),ON,OFF)
 
+NETOPEER2_MAKE_ENV = SYSREPOCTL_EXECUTABLE=$(HOST_DIR)/bin/sysrepoctl
+
 define NETOPEER2_INSTALL_INIT_SYSV
        $(INSTALL) -m 755 -D package/netopeer2/S52netopeer2 \
                $(TARGET_DIR)/etc/init.d/S52netopeer2