libgeotiff: explicit optional dependencies on zlib and jpeg
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 9 Oct 2014 16:10:46 +0000 (18:10 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 10 Oct 2014 06:36:09 +0000 (08:36 +0200)
In order to provide consistent behavior, this commit explicits the
optional dependencies of libgeotiff on zlib and jpeg.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libgeotiff/libgeotiff.mk

index 722e71c6fc3aa4941052a18d73637abcf00dcd64..61f5c219c49eaf306fb287e49535c120ff0fdfc9 100644 (file)
@@ -10,4 +10,18 @@ LIBGEOTIFF_DEPENDENCIES = tiff host-pkgconf
 LIBGEOTIFF_INSTALL_STAGING = YES
 LIBGEOTIFF_AUTORECONF = YES
 
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+LIBGEOTIFF_DEPENDENCIES += zlib
+LIBGEOTIFF_CONF_OPTS += --with-zlib
+else
+LIBGEOTIFF_CONF_OPTS += --without-zlib
+endif
+
+ifeq ($(BR2_PACKAGE_JPEG),y)
+LIBGEOTIFF_DEPENDENCIES += jpeg
+LIBGEOTIFF_CONF_OPTS += --with-jpeg
+else
+LIBGEOTIFF_CONF_OPTS += --without-jpeg
+endif
+
 $(eval $(autotools-package))