gettext: force build libintl if needed
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 14:47:47 +0000 (16:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 17:09:51 +0000 (19:09 +0200)
This commit introduces a hidden option
BR2_PACKAGE_GETTEXT_PROVIDES_INTL that is used by gettext.mk to force
the build of libintl if the toolchain doesn't provide a full gettext
implementation.

For now, this hidden option is not selected by anything, but a
follow-up commit will introduce BR2_ENABLE_NLS, which will make use of
it.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gettext/Config.in
package/gettext/gettext.mk

index 7871a480a859d1841ce5bca89cd73cbf400702d5..18bfda6461a111253b6bcb2a4e5fa67c171ff7c7 100644 (file)
@@ -12,6 +12,14 @@ config BR2_PACKAGE_GETTEXT
 
          http://www.gnu.org/software/gettext/
 
+if BR2_PACKAGE_GETTEXT
+
+config BR2_PACKAGE_GETTEXT_PROVIDES_LIBINTL
+       bool
+       depends on !BR2_TOOLCHAIN_HAS_FULL_GETTEXT
+
+endif
+
 comment "gettext needs a toolchain w/ wchar"
        depends on BR2_NEEDS_GETTEXT
        depends on !BR2_USE_WCHAR
index 498dfab8c7474b435e99e5ec2331525e9695e92c..454ad298a936463cf7eabc2cecb7e29695767388 100644 (file)
@@ -39,6 +39,14 @@ HOST_GETTEXT_CONF_OPTS = \
        --disable-relocatable \
        --without-emacs
 
+# Force the build of libintl, even if the C library provides a stub
+# gettext implementation
+ifeq ($(BR2_PACKAGE_GETTEXT_PROVIDES_LIBINTL),y)
+GETTEXT_CONF_OPTS += --with-included-gettext
+else
+GETTEXT_CONF_OPTS += --without-included-gettext
+endif
+
 # For the target version, we only need the runtime, and for the host
 # version, we only need the tools.
 GETTEXT_SUBDIR = gettext-runtime