vorbis-tools: fix libm linking issue
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 27 Jan 2014 13:51:40 +0000 (14:51 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 27 Jan 2014 13:51:40 +0000 (14:51 +0100)
Fixes http://autobuild.buildroot.net/results/d48/d488dc5e1d684124e7367dac00ba2fb8c7b1b876/

ogg123 calls math functions but forgets to link with libm.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/vorbis-tools/vorbis-tools.mk

index 464081e7aec364f46fd31b527bbbeddc0ae596db..506f8b94dfe1f8f18a40ad4028b63c23e2ca09df 100644 (file)
@@ -10,6 +10,8 @@ VORBIS_TOOLS_LICENSE = GPLv2
 VORBIS_TOOLS_LICENSE_FILES = COPYING
 VORBIS_TOOLS_DEPENDENCIES = libao libogg libvorbis libcurl
 VORBIS_TOOLS_CONF_OPT = --program-transform-name=''
+# ogg123 calls math functions but forgets to link with libm
+VORBIS_TOOLS_CONF_ENV = LIBS=-lm
 
 ifeq ($(BR2_PACKAGE_FLAC),y)
 VORBIS_TOOLS_DEPENDENCIES += flac