raptor: new package
authorMatt Weber <matthew.weber@rockwellcollins.com>
Tue, 22 Mar 2016 10:14:01 +0000 (15:44 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 26 Mar 2016 18:14:16 +0000 (19:14 +0100)
Raptor is a free software / Open Source C library that provides a set of parsers
and serializers that generate Resource Description Framework (RDF) triples
by parsing syntaxes or serialize the triples into a syntax.

http://librdf.org/raptor/

Patch added in the package:
0001-configure.ac-remove-conditional-lib-inclusion.patch

Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Nitin Mendiratta <nitin.mendiratta@rockwellcollins.com>
[Thomas:
 - add else clause for the three optional dependencies, as suggested
   by Baruch.
 - fix they yajl optional dependency, as noticed by Baruch.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/raptor/0001-configure.ac-remove-conditional-lib-inclusion.patch [new file with mode: 0644]
package/raptor/Config.in [new file with mode: 0644]
package/raptor/raptor.hash [new file with mode: 0644]
package/raptor/raptor.mk [new file with mode: 0644]

index 1467f33bff93e9e5c4eeb1ead05fab7900f7e9ac..8208da87d780d880cb2337214362157031c7fc37 100644 (file)
@@ -1039,6 +1039,7 @@ menu "JSON/XML"
        source "package/mxml/Config.in"
        source "package/rapidjson/Config.in"
        source "package/rapidxml/Config.in"
+       source "package/raptor/Config.in"
        source "package/tinyxml/Config.in"
        source "package/tinyxml2/Config.in"
        source "package/xerces/Config.in"
diff --git a/package/raptor/0001-configure.ac-remove-conditional-lib-inclusion.patch b/package/raptor/0001-configure.ac-remove-conditional-lib-inclusion.patch
new file mode 100644 (file)
index 0000000..7367ad2
--- /dev/null
@@ -0,0 +1,21 @@
+Removed header Include path from the configure file as path was
+from the host, which is wrong for the cross compilation.
+Upstream: None
+
+Signed-off-by: Nitin Mendiratta <nitin.mendiratta@rockwellcollins.com>
+
+diff --git a/configure.ac b/configure.ac
+index 10ff870..27b9957 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1145,9 +1145,7 @@ have_lininn=no
+ have_inn_parsedate=no
+ oCPPFLAGS="$CPPFLAGS"
+-if test -d /usr/include/inn; then
+-  CPPFLAGS="$CPPFLAGS -I/usr/include/inn"
+-fi
++
+ AC_CHECK_HEADER(libinn.h)
+ CPPFLAGS="$oCPPFLAGS"
diff --git a/package/raptor/Config.in b/package/raptor/Config.in
new file mode 100644 (file)
index 0000000..65979a2
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_RAPTOR
+       bool "raptor"
+       select BR2_PACKAGE_LIBXML2
+       select BR2_PACKAGE_LIBXSLT
+       help
+         A C library that provides a set of parsers and
+         serializers that generate Resource Description
+         Framework (RDF) triples by parsing syntaxes or
+         serialize the triples into a syntax.
+
+         http://librdf.org/raptor/
diff --git a/package/raptor/raptor.hash b/package/raptor/raptor.hash
new file mode 100644 (file)
index 0000000..ee7a71b
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 ada7f0ba54787b33485d090d3d2680533520cd4426d2f7fb4782dd4a6a1480ed raptor2-2.0.15.tar.gz
diff --git a/package/raptor/raptor.mk b/package/raptor/raptor.mk
new file mode 100644 (file)
index 0000000..aea14e3
--- /dev/null
@@ -0,0 +1,43 @@
+################################################################################
+#
+# raptor
+#
+################################################################################
+
+RAPTOR_VERSION = 2.0.15
+RAPTOR_SOURCE = raptor2-$(RAPTOR_VERSION).tar.gz
+RAPTOR_SITE = http://download.librdf.org/source
+RAPTOR_DEPENDENCIES = libxml2 libxslt
+RAPTOR_LICENSE = GPLv2+ or LGPLv2.1+ or Apache-2.0+
+RAPTOR_LICENSE_FILES = LICENSE.txt
+
+# Flag is added to make sure the patch is applied for the configure.ac of raptor.
+RAPTOR_AUTORECONF = YES
+
+RAPTOR_CONF_OPTS =\
+       --with-xml2-config=$(STAGING_DIR)/usr/bin/xml2-config \
+       --with-xslt-config=$(STAGING_DIR)/usr/bin/xslt-config
+
+ifeq ($(BR2_PACKAGE_LIBCURL),y)
+RAPTOR_DEPENDENCIES += libcurl
+RAPTOR_CONF_OPTS += --with-curl-config=$(STAGING_DIR)/usr/bin/curl-config
+else
+RAPTOR_CONF_OPTS += --with-curl-config=no
+endif
+
+ifeq ($(BR2_PACKAGE_YAJL),y)
+RAPTOR_DEPENDENCIES += yajl
+RAPTOR_CONF_ENV += LIBS="-lm"
+RAPTOR_CONF_OPTS += --with-yajl=$(STAGING_DIR)/usr
+else
+RAPTOR_CONF_OPTS += --with-yajl=no
+endif
+
+ifeq ($(BR2_PACKAGE_ICU),y)
+RAPTOR_DEPENDENCIES += icu
+RAPTOR_CONF_OPTS += --with-icu-config=$(STAGING_DIR)/usr/bin/icu-config
+else
+RAPTOR_CONF_OPTS += --with-icu-config=no
+endif
+
+$(eval $(autotools-package))