python: use system libffi for host-python
authorErico Nunes <nunes.erico@gmail.com>
Mon, 21 Jun 2021 05:53:51 +0000 (22:53 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 27 Jun 2021 15:54:58 +0000 (17:54 +0200)
python2 contains a bundled copy of libffi which is currently out of sync with
the latest libffi release. There is an option to use a system libffi, buildroot
already uses it for the target python2 build and for python3. In python3, the
bundled copy doesn't exist anymore and the system-provided libffi is required.

The bundled copy currently fails to build on aarch64 host due to a missing
definition of AARCH64_CALL_CONTEXT_SIZE. This define was removed from the
headers in recent libffi releases and the host compiler might be including the
system headers before the bundled headers.

To solve this and since buildroot already relies on system libffi for target
python2 and python3 anyway, switch host python2 to use system libffi.

Signed-off-by: Erico Nunes <nunes.erico@gmail.com>
Reviewed-by: Christian Stewart <christian@paral.in>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/python/python.mk

index f4f9f8563b3d46fe76c3b02091f92dd1bf341921..ae99f382f9cc622a680db40f5416336e70170617 100644 (file)
@@ -24,6 +24,7 @@ HOST_PYTHON_CONF_OPTS += \
        --disable-sqlite3 \
        --disable-tk \
        --with-expat=system \
+       --with-system-ffi \
        --disable-curses \
        --disable-codecs-cjk \
        --disable-nis \
@@ -56,7 +57,7 @@ HOST_PYTHON_MAKE = $(MAKE1)
 
 PYTHON_DEPENDENCIES = host-python libffi $(TARGET_NLS_DEPENDENCIES)
 
-HOST_PYTHON_DEPENDENCIES = host-expat host-zlib
+HOST_PYTHON_DEPENDENCIES = host-expat host-libffi host-zlib
 
 ifeq ($(BR2_PACKAGE_HOST_PYTHON_SSL),y)
 HOST_PYTHON_DEPENDENCIES += host-openssl