imagemagick: fix magick++-config fixup error
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 12 Aug 2013 12:06:58 +0000 (09:06 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 13 Aug 2013 08:16:11 +0000 (10:16 +0200)
Magic++ bindings are built only with C++ and WCHAR toolchains.
Add a WCHAR toolchain check for the magick++ config fixup.
Looking into the future the fixup shouldn't bail on a missing file so we
can avoid awkward kludges for packages that have many options and config
files.
Fixes:
http://autobuild.buildroot.net/results/33a/33ac4b17866a64379b7bab3c0549f6e075c98dde/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/imagemagick/imagemagick.mk

index 12b9f4b2533cfeaa2f608a5871772c12ddfaa5a6..21495749d09883f1c483212642d595edd494ce94 100644 (file)
@@ -19,7 +19,7 @@ IMAGEMAGICK_AUTORECONF = YES
 IMAGEMAGICK_CONFIG_SCRIPTS = \
        $(addsuffix -config,Magick MagickCore MagickWand Wand)
 
-ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+ifeq ($(BR2_INSTALL_LIBSTDCPP)$(BR2_USE_WCHAR),yy)
 IMAGEMAGICK_CONFIG_SCRIPTS += Magick++-config
 endif