package/python3: adjust _REMOVE_USELESS_FILES fix for new layout
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 2 Aug 2019 17:43:59 +0000 (19:43 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 3 Aug 2019 18:23:35 +0000 (20:23 +0200)
python3 nowadays appends the triplet to the config-<version>m directory:

echo target/usr/lib/python3.7/config-*
target/usr/lib/python3.7/config-3.7m-powerpc-linux-gnu

Likewise, there is no longer a pyconfig.h:

ls target/usr/lib/python3.7/config-3.7m-powerpc-linux-gnu
config.c  config.c.in  install-sh  libpython3.7m.a  Makefile
makesetup  python-config.py  python.o  Setup  Setup.local

So adjust the removal logic to match.  Use a wildcard rather than
$GNU_TARGET_NAME as buildroot and python3's idea of the triplet doesn't
always match (E.G.  for musl/uclibc).

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/python3/python3.mk

index decae1b721f6f322778edf0e997e3af4c48940bd..8e6a0296edb92b2558775e6eb43dd59313b0d92b 100644 (file)
@@ -203,8 +203,8 @@ define PYTHON3_REMOVE_USELESS_FILES
        rm -f $(TARGET_DIR)/usr/bin/python$(PYTHON3_VERSION_MAJOR)m-config
        rm -f $(TARGET_DIR)/usr/bin/python3-config
        rm -f $(TARGET_DIR)/usr/bin/smtpd.py.3
-       for i in `find $(TARGET_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)/config-$(PYTHON3_VERSION_MAJOR)m/ \
-               -type f -not -name pyconfig.h -a -not -name Makefile` ; do \
+       for i in `find $(TARGET_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)/config-$(PYTHON3_VERSION_MAJOR)m-*/ \
+               -type f -not -name Makefile` ; do \
                rm -f $$i ; \
        done
        rm -rf $(TARGET_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)/__pycache__/