gnutls: make sure librt detection doesn't poison the linker flags
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 14 Feb 2015 21:18:51 +0000 (22:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 Feb 2015 12:58:22 +0000 (13:58 +0100)
Just like we're passing --with-libpthread-prefix, we also need to pass
--with-librt-prefix in order to avoid having the gnutls build system
detect the librt in /usr/lib, and pass -L/usr/lib to the linker flags.

Fixes:

  http://autobuild.buildroot.org/results/fa5/fa58602cb78ffe3ae4ee389ef5cf5a37b7657c4c/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gnutls/gnutls.mk

index ab176a6476ced2295bd7013415300a98c9d7adce..6c64b383aa142bd0123140c8d255e4aa34964a1d 100644 (file)
@@ -17,6 +17,7 @@ GNUTLS_DEPENDENCIES = host-pkgconf nettle pcre \
        $(if $(BR2_PACKAGE_ZLIB),zlib)
 GNUTLS_CONF_OPTS = \
        --with-libnettle-prefix=$(STAGING_DIR)/usr \
+       --with-librt-prefix=$(STAGING_DIR) \
        --disable-rpath \
        --disable-doc \
        --disable-guile \