package: remove non-conventional prefix/suffix from github-fetched packages
authorVictor Huesca <victor.huesca@bootlin.com>
Wed, 12 Jun 2019 06:42:08 +0000 (08:42 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 19 Jun 2019 21:26:35 +0000 (23:26 +0200)
On Github, a large number of projects name their tag
<some-prefix>-0.3-<some-suffix> (i.e release-3.0, poco-0.1-release,
etc.). In fact majority of the cased adressed in this commit concerns
prefixes.

In most packages, we encode those prefix/suffix in the <pkg>_VERSION
variable.

The problem with this approach is that when used in conjunction with
release-monitoring.org, it doesn't work very well, because
release-monitoring.org has the concept of "version prefix/suffix" and
using that they drop the prefix/suffix to really get the version. For
example on https://release-monitoring.org/project/5418/ the latest
release of "poco" is "1.8.1", not "poco-1.8.1-release".

Therefore, a number of packages in Buildroot have a version that
doesn't match with release-monitoring.org.

Since really the version number of 1.8.1, is makes sense to update our
packages to drop these prefixes/suffixes.

This commit addreses the case of github-fetched packages with
non-conventional prefixes/suffixes.

Note that these changes modify the name of the files stored in DL_DIR,
which means that this will force a re-download of those package source
code for all users, and requires a change to their .hash file.

Signed-off-by: Victor Huesca <victor.huesca@bootlin.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
30 files changed:
package/emlog/emlog.hash
package/emlog/emlog.mk
package/gtest/gtest.hash
package/gtest/gtest.mk
package/intel-microcode/intel-microcode.hash
package/intel-microcode/intel-microcode.mk
package/iputils/iputils.hash
package/iputils/iputils.mk
package/jasper/jasper.hash
package/jasper/jasper.mk
package/libnfs/libnfs.hash
package/libnfs/libnfs.mk
package/libusbgx/libusbgx.hash
package/libusbgx/libusbgx.mk
package/lua-cqueues/lua-cqueues.hash
package/lua-cqueues/lua-cqueues.mk
package/motion/motion.hash
package/motion/motion.mk
package/openjdk/openjdk.hash
package/openjdk/openjdk.mk
package/poco/poco.hash
package/poco/poco.mk
package/ptpd2/ptpd2.hash
package/ptpd2/ptpd2.mk
package/python-web2py/python-web2py.hash
package/python-web2py/python-web2py.mk
package/python-webpy/python-webpy.hash
package/python-webpy/python-webpy.mk
package/xinetd/xinetd.hash
package/xinetd/xinetd.mk

index 9d81d47ec24197009ff68a8eb5eb820a3215281c..ba0a201acbe22f0455132eac8c270351ca672b13 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 9f791a00c86215306597b761ef5c5ad267efee5f01efbe23cfcc04e583aa402d  emlog-emlog-0.60.tar.gz
+sha256 9f791a00c86215306597b761ef5c5ad267efee5f01efbe23cfcc04e583aa402d  emlog-0.60.tar.gz
index e0926e6cbdb85d6497e2b1120cc33e492ddd033c..42e3c9dd7b09441179b5c7a416df6cbd1eee7a05 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-EMLOG_VERSION = emlog-0.60
-EMLOG_SITE = $(call github,nicupavel,emlog,$(EMLOG_VERSION))
+EMLOG_VERSION = 0.60
+EMLOG_SITE = $(call github,nicupavel,emlog,emlog-$(EMLOG_VERSION))
 EMLOG_LICENSE = GPL-2.0
 EMLOG_LICENSE_FILES = COPYING
 
index 0a8d8ba096731981cb2e6d1c03c7d996a3e53aa0..aa42570eb22ff1fdc02d774438ee2bcfa3bd4504 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed:
-sha256 58a6f4277ca2bc8565222b3bbd58a177609e9c488e8a72649359ba51450db7d8        gtest-release-1.8.0.tar.gz
+sha256 58a6f4277ca2bc8565222b3bbd58a177609e9c488e8a72649359ba51450db7d8        gtest-1.8.0.tar.gz
 sha256 9702de7e4117a8e2b20dafab11ffda58c198aede066406496bef670d40a22138        googletest/LICENSE
index b62ceb32709443d6ab9702e092ddd4c3306e41d6..f26098bad7b95ced4857e1d80aaa58faceffb8de 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-GTEST_VERSION = release-1.8.0
-GTEST_SITE = $(call github,google,googletest,$(GTEST_VERSION))
+GTEST_VERSION = 1.8.0
+GTEST_SITE = $(call github,google,googletest,release-$(GTEST_VERSION))
 GTEST_INSTALL_STAGING = YES
 GTEST_INSTALL_TARGET = NO
 GTEST_LICENSE = BSD-3-Clause
index 257cc85c411055f060abca28cfafb985c7a3525f..bb474ad2bb04dafea5e07f3e35afc93f874f32ec 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256 9e67903a5b62b51f5e031b59a8046d3dff226834d79899799943803481a55d20  intel-microcode-microcode-20190514a.tar.gz
+sha256 9e67903a5b62b51f5e031b59a8046d3dff226834d79899799943803481a55d20  intel-microcode-20190514a.tar.gz
 sha256 1f8bf63fc2b1b486c507b98ff7d283c7eb58c7945746b94188a310d6787cbee5  license
index dacb619a14e9e33c1a0acc69e73137b8554de8fe..1279a1d364ec9ee00968883b3ac8cb1285fd3638 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-INTEL_MICROCODE_VERSION = microcode-20190514a
-INTEL_MICROCODE_SITE = $(call github,intel,Intel-Linux-Processor-Microcode-Data-Files,$(INTEL_MICROCODE_VERSION))
+INTEL_MICROCODE_VERSION = 20190514a
+INTEL_MICROCODE_SITE = $(call github,intel,Intel-Linux-Processor-Microcode-Data-Files,microcode-$(INTEL_MICROCODE_VERSION))
 INTEL_MICROCODE_LICENSE = PROPRIETARY
 INTEL_MICROCODE_LICENSE_FILES = license
 INTEL_MICROCODE_REDISTRIBUTE = NO
index 613414ce5cf65cca5cdf4eeeb0abd173864f0c7a..0e2963dda25177e94479c8e066f937a00bbec378 100644 (file)
@@ -1,5 +1,5 @@
 # Locally computed
-sha256 9b5125eb5ef9f4e947ad8fdddcf77f538f53b8f47b53eb5bc5347cb16d01c8fd  iputils-s20190515.tar.gz
+sha256 9b5125eb5ef9f4e947ad8fdddcf77f538f53b8f47b53eb5bc5347cb16d01c8fd  iputils-20190515.tar.gz
 sha256 b8ea785d12fa6a44916601104dd746216957e93f13a26d3eb858b3b5a4ad66ab  LICENSE
 sha256 9acc4bc871a4742550158e3696dcb381953172ef808d04ca248184f9f6322712  Documentation/LICENSE.BSD3
 sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  Documentation/LICENSE.GPL2
index 052110878a51773b7cf771c84e94188adb695a79..1ae5d83bf395d809f41294fe5876398bba3deb00 100644 (file)
@@ -11,8 +11,8 @@
 # and IPv6 updates.
 # http://www.spinics.net/lists/netdev/msg279881.html
 
-IPUTILS_VERSION = s20190515
-IPUTILS_SITE = $(call github,iputils,iputils,$(IPUTILS_VERSION))
+IPUTILS_VERSION = 20190515
+IPUTILS_SITE = $(call github,iputils,iputils,s$(IPUTILS_VERSION))
 IPUTILS_LICENSE = GPL-2.0+, BSD-3-Clause
 IPUTILS_LICENSE_FILES = LICENSE Documentation/LICENSE.BSD3 Documentation/LICENSE.GPL2
 IPUTILS_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
index 4fea367ebc061f26efb35568c2be8f19d1aac47a..036ebc88d7fa8a55e8d07d92e5ca33a9e4c79f63 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 85266eea728f8b14365db9eaf1edc7be4c348704e562bb05095b9a077cf1a97b  jasper-version-2.0.14.tar.gz
+sha256 85266eea728f8b14365db9eaf1edc7be4c348704e562bb05095b9a077cf1a97b  jasper-2.0.14.tar.gz
 sha256 4ad1bb42aff888c4403d792e6e2c5f1716d6c279fea70b296333c9d577d30b81  LICENSE
index 31fded779b3a8f1163abf96193afec302dfddc6e..f1260f2a9c44c8549470a6e23bb1f899fcc2656d 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-JASPER_VERSION = version-2.0.14
-JASPER_SITE = $(call github,mdadams,jasper,$(JASPER_VERSION))
+JASPER_VERSION = 2.0.14
+JASPER_SITE = $(call github,mdadams,jasper,version-$(JASPER_VERSION))
 JASPER_INSTALL_STAGING = YES
 JASPER_LICENSE = JasPer-2.0
 JASPER_LICENSE_FILES = LICENSE
index 9cd2fd71c5942abe6978b291c43d640ed74799f4..bb92ebe6976ccf12400caf8b2a6508b2323ce09b 100644 (file)
@@ -1,5 +1,5 @@
 # Locally calculated
-sha256 6ee77e9fe220e2d3e3b1f53cfea04fb319828cc7dbb97dd9df09e46e901d797d  libnfs-libnfs-4.0.0.tar.gz
+sha256 6ee77e9fe220e2d3e3b1f53cfea04fb319828cc7dbb97dd9df09e46e901d797d  libnfs-4.0.0.tar.gz
 sha256 edd960c0142b8ada98b43b6396b78f4e557b0bc70ac601a51e397ad04070e2c5  COPYING
 sha256 d9406ced95457941032aa11d04623b8ab71f2827a3395ebef137aec475be35b1  LICENCE-BSD.txt
 sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  LICENCE-LGPL-2.1.txt
index 5c8f66b011b68090ce98c749b5de6931c83a23dd..5f950b5cdebae9240c24e9a8babb849f4a1a972e 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-LIBNFS_VERSION = libnfs-4.0.0
-LIBNFS_SITE = $(call github,sahlberg,libnfs,$(LIBNFS_VERSION))
+LIBNFS_VERSION = 4.0.0
+LIBNFS_SITE = $(call github,sahlberg,libnfs,libnfs-$(LIBNFS_VERSION))
 LIBNFS_INSTALL_STAGING = YES
 LIBNFS_AUTORECONF = YES
 LIBNFS_LICENSE = LGPL-2.1+ (library), BSD-2-Clause (protocol, .x files), GPL-3.0+ (examples)
index 107123ae114f018d00d352d62dae12154c294291..dd43ec7b978fd6c5359836eb61e6c5285ee2bb99 100644 (file)
@@ -1,4 +1,4 @@
 # Locally computed:
-sha256  b15abc89a0ef82c6a650cc1d58b5ba50f7ce076db392add84caabcd86c608ee2  libusbgx-libusbgx-v0.2.0.tar.gz
+sha256  b15abc89a0ef82c6a650cc1d58b5ba50f7ce076db392add84caabcd86c608ee2  libusbgx-0.2.0.tar.gz
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING
 sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING.LGPL
index e7c082f9f37e0e06193a10a7204e1d6307ef7844..516ad259702e1ae7035fc8d1230556671ce2244b 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-LIBUSBGX_VERSION = libusbgx-v0.2.0
-LIBUSBGX_SITE = $(call github,libusbgx,libusbgx,$(LIBUSBGX_VERSION))
+LIBUSBGX_VERSION = 0.2.0
+LIBUSBGX_SITE = $(call github,libusbgx,libusbgx,libusbgx-v$(LIBUSBGX_VERSION))
 LIBUSBGX_LICENSE = GPL-2.0+ (examples), LGPL-2.1+ (library)
 LIBUSBGX_LICENSE_FILES = COPYING COPYING.LGPL
 LIBUSBGX_DEPENDENCIES = host-pkgconf libconfig
index 9fd664d69a0f2924498a465cd8b332ad8846696b..7824c08f9b1db91c0cf8f5b7a151130ae90974dc 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 ae51b713bdf966215b87244e03ac60b5a12beb82d15dfb02755a000cfb2df905  lua-cqueues-rel-20161215.tar.gz
+sha256 ae51b713bdf966215b87244e03ac60b5a12beb82d15dfb02755a000cfb2df905  lua-cqueues-20161215.tar.gz
index 42dacc19469f9fc32a4c9d0c78c5cddd5decad62..8f94386fb3fcb264896c8d6eec07ef7e632a647c 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-LUA_CQUEUES_VERSION = rel-20161215
-LUA_CQUEUES_SITE = $(call github,wahern,cqueues,$(LUA_CQUEUES_VERSION))
+LUA_CQUEUES_VERSION = 20161215
+LUA_CQUEUES_SITE = $(call github,wahern,cqueues,rel-$(LUA_CQUEUES_VERSION))
 LUA_CQUEUES_LICENSE = MIT
 LUA_CQUEUES_LICENSE_FILES = LICENSE
 LUA_CQUEUES_DEPENDENCIES = luainterpreter openssl host-m4
index 679defa3d3dba8c9adb1a64fd04e72b0095c995c..4ce70f8640e69578cf758def5a47d0ef1841e3be 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed:
-sha256 d97ec6ae766adfd478b6f7f9cc0da5f2fe21faa9366d98664be255714c1cf81d        motion-release-4.2.1.tar.gz
+sha256 d97ec6ae766adfd478b6f7f9cc0da5f2fe21faa9366d98664be255714c1cf81d        motion-4.2.1.tar.gz
 sha256 91df39d1816bfb17a4dda2d3d2c83b1f6f2d38d53e53e41e8f97ad5ac46a0cad        COPYING
index 6dfc5a56196b464fb9497ea072b9949add060a38..eb7f75e3fb7cd97ccb1dc69639c26d55f3814920 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-MOTION_VERSION = release-4.2.1
-MOTION_SITE = $(call github,Motion-Project,motion,$(MOTION_VERSION))
+MOTION_VERSION = 4.2.1
+MOTION_SITE = $(call github,Motion-Project,motion,release-$(MOTION_VERSION))
 MOTION_LICENSE = GPL-2.0
 MOTION_LICENSE_FILES = COPYING
 MOTION_DEPENDENCIES = host-pkgconf jpeg libmicrohttpd $(TARGET_NLS_DEPENDENCIES)
index 91d0f1dbceca7b18bf401c040c499f786ce78701..e94d4d6d44e71bf171b39979e78913db943dd886 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256 de278328668bdaf35d50d0319d15d64d195ddd8a0de9c6fde3a6c9ca10135a92  openjdk-jdk-12+33.tar.gz
+sha256 de278328668bdaf35d50d0319d15d64d195ddd8a0de9c6fde3a6c9ca10135a92  openjdk-12+33.tar.gz
 sha256 4b9abebc4338048a7c2dc184e9f800deb349366bdf28eb23c2677a77b4c87726  LICENSE
index 91a00870c58279219213095ecd6091a938723f5d..e6e834cde9b31f9a5087b4c8dcea79c552e6ba73 100644 (file)
@@ -6,8 +6,8 @@
 
 OPENJDK_VERSION_MAJOR = 12
 OPENJDK_VERSION_MINOR = 33
-OPENJDK_VERSION = jdk-$(OPENJDK_VERSION_MAJOR)+$(OPENJDK_VERSION_MINOR)
-OPENJDK_SITE = $(call github,AdoptOpenJDK,openjdk-jdk12u,$(OPENJDK_VERSION))
+OPENJDK_VERSION = $(OPENJDK_VERSION_MAJOR)+$(OPENJDK_VERSION_MINOR)
+OPENJDK_SITE = $(call github,AdoptOpenJDK,openjdk-jdk12u,jdk-$(OPENJDK_VERSION))
 OPENJDK_LICENSE = GPL-2.0+ with exception
 OPENJDK_LICENSE_FILES = LICENSE
 
index 0c0266f47245b5b3507be637e839d2f43d494446..33e60dba45a7884be1853d3b689c2958595d4e56 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256  43cc469c01d1f799efc51e2bfde6ffdf467b98a8a0901e6b33db86958619b3af  poco-poco-1.8.1-release.tar.gz
+sha256  43cc469c01d1f799efc51e2bfde6ffdf467b98a8a0901e6b33db86958619b3af  poco-1.8.1.tar.gz
 sha256  c4b1e1e5f36d8331737231fefcc30f5714326aec7c387ad59a8115eb0ba7d6b5  LICENSE
index aa96d5127b71981eae633b7889ac2e3b03f6dc0f..7283447f9dd9555e15f747c025c5191d6cbaae73 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-POCO_VERSION = poco-1.8.1-release
-POCO_SITE = $(call github,pocoproject,poco,$(POCO_VERSION))
+POCO_VERSION = 1.8.1
+POCO_SITE = $(call github,pocoproject,poco,poco-$(POCO_VERSION)-release)
 POCO_LICENSE = BSL-1.0
 POCO_LICENSE_FILES = LICENSE
 POCO_INSTALL_STAGING = YES
index af1f78a5a899ed2d9d8e566e33bd2b41b97d7875..0a7379a1d8d97cd57864eec23b2da02b8039c3f1 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed:
-sha256 267ad61d09d97069acec5d4878dceda20d0ddbebd27557d80230847848cee6c2        ptpd2-ptpd-2.3.1.tar.gz
+sha256 267ad61d09d97069acec5d4878dceda20d0ddbebd27557d80230847848cee6c2        ptpd2-2.3.1.tar.gz
index c0c414ae830175f28fd4dd1aa83ff99adac53925..f4a70760ad5f2918b6799b68348955a8cd7bd44b 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-PTPD2_VERSION = ptpd-2.3.1
-PTPD2_SITE = $(call github,ptpd,ptpd,$(PTPD2_VERSION))
+PTPD2_VERSION = 2.3.1
+PTPD2_SITE = $(call github,ptpd,ptpd,ptpd-$(PTPD2_VERSION))
 PTPD2_DEPENDENCIES = libpcap
 PTPD2_CONF_OPTS = --with-pcap-config=$(STAGING_DIR)/usr/bin/pcap-config
 # configure not shipped
index 9a1df0c2a17db7e53a150b07aedfdd05eb354638..57ac02c2a90e65b66cccdbf912d6dc8bac02e739 100644 (file)
@@ -1,3 +1,3 @@
 # sha256 locally computed
-sha256 8205a7a08595ca1a41919750a8dc4e431258966cb46c8021564b25003cf90863  python-web2py-R-2.17.2.tar.gz
+sha256 8205a7a08595ca1a41919750a8dc4e431258966cb46c8021564b25003cf90863  python-web2py-2.17.2.tar.gz
 sha256 2aae96826184a492bc799add49aed7b29036e7aba2d2294fb65053bd30fe55fe  LICENSE
index 922b267b8b22a2ce8f797dd8304a4f0fa1df8cb9..0b86fb148e3c4d65b0c45440fd63ed66d393ef7b 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-PYTHON_WEB2PY_VERSION = R-2.17.2
-PYTHON_WEB2PY_SITE = $(call github,web2py,web2py,$(PYTHON_WEB2PY_VERSION))
+PYTHON_WEB2PY_VERSION = 2.17.2
+PYTHON_WEB2PY_SITE = $(call github,web2py,web2py,R-$(PYTHON_WEB2PY_VERSION))
 PYTHON_WEB2PY_LICENSE = LGPL-3.0
 PYTHON_WEB2PY_LICENSE_FILES = LICENSE
 PYTHON_WEB2PY_DEPENDENCIES = $(if $(BR2_PACKAGE_PYTHON3),host-python3 python3,host-python python) \
index 70981e0cb4108b5b8f225b850cbfdc9d27e8ec0e..8ac6827538e3925f9c9418032d26796de64eb26f 100644 (file)
@@ -1,4 +1,4 @@
 # Locally computed
-sha256  f074241a0b839408a0b9840ade1198e16fbd6aa6393a48a0e84f73b545baab9a  python-webpy-webpy-0.39.tar.gz
+sha256  f074241a0b839408a0b9840ade1198e16fbd6aa6393a48a0e84f73b545baab9a  python-webpy-0.39.tar.gz
 sha256  3826fd531a9b904841f5e3560fcda7e93f2ab8d11ef124ec65e10625efa26c34  LICENSE.txt
 sha256  7347fd17bfd33c4093c31dc77076733e1e0150ce8c13296c56dc042bbecede84  web/wsgiserver/LICENSE.txt
index 192ba5727fb65b5dd736e9405fd8d8fc5ff018e7..86812a04cbc37f75e2f145ec50a9c8404474b2e9 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-PYTHON_WEBPY_VERSION = webpy-0.39
-PYTHON_WEBPY_SITE = $(call github,webpy,webpy,$(PYTHON_WEBPY_VERSION))
+PYTHON_WEBPY_VERSION = 0.39
+PYTHON_WEBPY_SITE = $(call github,webpy,webpy,webpy-$(PYTHON_WEBPY_VERSION))
 PYTHON_WEBPY_SETUP_TYPE = setuptools
 PYTHON_WEBPY_LICENSE = Public Domain, CherryPy License
 PYTHON_WEBPY_LICENSE_FILES = LICENSE.txt web/wsgiserver/LICENSE.txt
index 051436613c09255f23c767d253812bf4676461a5..d02d6d3a507aa2a2f2449368efaac8b22a9dfd81 100644 (file)
@@ -1,2 +1,2 @@
 # locally computed
-sha256  620b25f4ab4d72fdf32b13797156ea40df2049f1c07e640177e5fec544e9a94c  xinetd-xinetd-2-3-15.tar.gz
+sha256  620b25f4ab4d72fdf32b13797156ea40df2049f1c07e640177e5fec544e9a94c  xinetd-2-3-15.tar.gz
index 98185122ce06b47c5af5228e098256ce3bf73e50..a2ba10df74aeeafcb335bb60e7f6606643b1034e 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-XINETD_VERSION = xinetd-2-3-15
-XINETD_SITE = $(call github,xinetd-org,xinetd,$(XINETD_VERSION))
+XINETD_VERSION = 2-3-15
+XINETD_SITE = $(call github,xinetd-org,xinetd,xinetd-$(XINETD_VERSION))
 XINETD_LICENSE = xinetd license
 XINETD_LICENSE_FILES = COPYRIGHT