package/hostapd: remove support for Realtek drivers
authorAlexander Mukhin <alexander.i.mukhin@gmail.com>
Fri, 6 Sep 2019 10:21:00 +0000 (13:21 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 7 Sep 2019 12:36:23 +0000 (14:36 +0200)
After hostapd update to 2.9, the patch provided no longer works,
although applies. Moreover, AP support for Realtek chips is broken
anyway in kernels > 4.9.

Signed-off-by: Alexander Mukhin <alexander.i.mukhin@gmail.com>
[Thomas: add Config.in.legacy handling]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
package/hostapd/Config.in
package/hostapd/hostapd.hash
package/hostapd/hostapd.mk

index 72c364ecb54aa7753ee6c7998adbdc635a98f1dc..61162e66e3ef4c100e6cba23b5150171702a7181 100644 (file)
@@ -146,6 +146,16 @@ endif
 
 comment "Legacy options removed in 2019.11"
 
+config BR2_PACKAGE_HOSTAPD_DRIVER_RTW
+       bool "hostapd rtl871xdrv driver removed"
+       select BR2_LEGACY
+       help
+         Since the update of hostapd to 2.9, the patch provided for
+         the rtl871xdrv no longer works, although it
+         applies. Moreover, AP support for Realtek chips is broken
+         anyway in kernels > 4.9. Therefore, this option has been
+         removed.
+
 config BR2_PACKAGE_WPA_SUPPLICANT_DBUS_NEW
        bool "new dbus support option in wpa_supplicant was renamed"
        select BR2_PACKAGE_WPA_SUPPLICANT_DBUS if BR2_TOOLCHAIN_HAS_THREADS
index 37c1126859757b62139bbc3e478428d804c69cc1..8a7abbb901a25110b22323a281c4add822b84bc0 100644 (file)
@@ -31,12 +31,6 @@ config BR2_PACKAGE_HOSTAPD_DRIVER_NL80211
 comment "nl80211 driver needs a toolchain w/ threads"
        depends on !BR2_TOOLCHAIN_HAS_THREADS
 
-config BR2_PACKAGE_HOSTAPD_DRIVER_RTW
-       bool "Enable rtl871xdrv driver"
-       select BR2_PACKAGE_HOSTAPD_HAS_WIFI_DRIVERS
-       help
-         Enable support for Realtek wireless chips.
-
 config BR2_PACKAGE_HOSTAPD_DRIVER_WIRED
        bool "Enable wired driver"
        help
@@ -47,7 +41,6 @@ config BR2_PACKAGE_HOSTAPD_DRIVER_NONE
        default y
        depends on !BR2_PACKAGE_HOSTAPD_DRIVER_HOSTAP
        depends on !BR2_PACKAGE_HOSTAPD_DRIVER_NL80211
-       depends on !BR2_PACKAGE_HOSTAPD_DRIVER_RTW
        depends on !BR2_PACKAGE_HOSTAPD_DRIVER_WIRED
 
 config BR2_PACKAGE_HOSTAPD_HAS_WIFI_DRIVERS
index 50225cf6d78dd729ce518c4c698fb86b9b3757a0..bf5016acc32181b1fc6129b181df44b5c2c1af1a 100644 (file)
@@ -1,4 +1,3 @@
 # Locally calculated
 sha256  881d7d6a90b2428479288d64233151448f8990ab4958e0ecaca7eeb3c9db2bd7  hostapd-2.9.tar.gz
-sha256  e204da659d0583c71af23cb9b55536fe99598ee26a44104344f456e4d17350c6  rtlxdrv.patch
 sha256  9da5dd0776da266b180b915e460ff75c6ff729aca1196ab396529510f24f3761  README
index f55e716a7cc8b6edb5cc98cf3bd137e67914ecf9..fb6ac8fb2e1aa4cc64d4dbb76b956d01c7ecd0b0 100644 (file)
@@ -39,11 +39,6 @@ ifeq ($(BR2_PACKAGE_HOSTAPD_DRIVER_NL80211),)
 HOSTAPD_CONFIG_DISABLE += CONFIG_DRIVER_NL80211
 endif
 
-ifeq ($(BR2_PACKAGE_HOSTAPD_DRIVER_RTW),y)
-HOSTAPD_PATCH += https://github.com/pritambaral/hostapd-rtl871xdrv/raw/master/rtlxdrv.patch
-HOSTAPD_CONFIG_SET += CONFIG_DRIVER_RTW
-endif
-
 ifeq ($(BR2_PACKAGE_HOSTAPD_DRIVER_WIRED),y)
 HOSTAPD_CONFIG_ENABLE += CONFIG_DRIVER_WIRED
 endif