package/hiawatha: reorder CONF_OPTS in the .mk file
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 29 May 2020 20:49:15 +0000 (22:49 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 29 May 2020 20:49:15 +0000 (22:49 +0200)
Move the unconditional CONF_OPTS assignment toward the beginning of
the file, before the conditionals on optional dependencies. And use =
for this unconditional assignment instead of +=. No functional
changes, just to align with the coding style used in most other
packages.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/hiawatha/hiawatha.mk

index 28fd286ea88b7f697c9de8fa776f30da5f9d031a..01b929203574c4fceda2ebfa0dc376cf400f6139 100644 (file)
@@ -10,6 +10,14 @@ HIAWATHA_DEPENDENCIES = zlib
 HIAWATHA_LICENSE = GPL-2.0
 HIAWATHA_LICENSE_FILES = LICENSE
 
+HIAWATHA_CONF_OPTS = \
+       -DENABLE_TOOLKIT=OFF \
+       -DCONFIG_DIR=/etc/hiawatha \
+       -DLOG_DIR=/var/log \
+       -DPID_DIR=/var/run \
+       -DWEBROOT_DIR=/var/www/hiawatha \
+       -DWORK_DIR=/var/lib/hiawatha
+
 ifeq ($(BR2_PACKAGE_HIAWATHA_SSL),y)
 HIAWATHA_CONF_OPTS += -DUSE_SYSTEM_MBEDTLS=ON
 HIAWATHA_DEPENDENCIES += mbedtls
@@ -24,12 +32,4 @@ else
 HIAWATHA_CONF_OPTS += -DENABLE_XSLT=OFF
 endif
 
-HIAWATHA_CONF_OPTS += \
-       -DENABLE_TOOLKIT=OFF \
-       -DCONFIG_DIR=/etc/hiawatha \
-       -DLOG_DIR=/var/log \
-       -DPID_DIR=/var/run \
-       -DWEBROOT_DIR=/var/www/hiawatha \
-       -DWORK_DIR=/var/lib/hiawatha
-
 $(eval $(cmake-package))