bash: Adding features that can not be automatically detected while cross-compiling
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 19 Jan 2012 12:22:08 +0000 (13:22 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 20 Jan 2012 08:06:00 +0000 (09:06 +0100)
There are some bash features that can not be detected automatically during
configure stage while cross-compiling. This commit forces them on.

Signed-off-by: Arkady Gilinsky <arcadyg@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/bash/bash.mk

index f1f951c3ab785d8cda18a40fddf7f23d8d98dfca..44f93377507aca168f556eac88dc57d999aafde9 100644 (file)
@@ -7,7 +7,11 @@
 BASH_VERSION = 4.2
 BASH_SITE = $(BR2_GNU_MIRROR)/bash
 BASH_DEPENDENCIES = ncurses
-BASH_CONF_ENV = bash_cv_job_control_missing=no
+BASH_CONF_ENV +=                       \
+   bash_cv_job_control_missing=present \
+   bash_cv_sys_named_pipes=present     \
+   bash_cv_func_sigsetjmp=present      \
+   bash_cv_printf_a_format=yes
 
 # Make sure we build after busybox so that /bin/sh links to bash
 ifeq ($(BR2_PACKAGE_BUSYBOX),y)