boost: Force the target ABI for MIPS architecture
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Wed, 3 Sep 2014 15:10:49 +0000 (16:10 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 4 Sep 2014 15:30:33 +0000 (17:30 +0200)
The default ABI used in boost is 'sysv' which is not valid for MIPS.
Given the boost build system doesn't detect the right ABI when we are
cross-compiling, we fix this by passing the right ABI directly to the
boost options for the target.

Related:
  https://svn.boost.org/trac/boost/ticket/10442

Fixes:
  http://autobuild.buildroot.net/results/79f/79fe4caffb9a3b9f1b203498a589a5172bd0acea/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/boost/boost.mk

index 2cd76ce08fab75cef19714f8871b04179a1fc38b..ac67e3c173661094a382259b042ee8beb0793c88 100644 (file)
@@ -82,6 +82,7 @@ HOST_BOOST_OPT += toolset=gcc threading=multi variant=release link=shared \
 
 BOOST_OPT += toolset=gcc \
             threading=multi \
+            abi=$(if $(BR2_MIPS_OABI32),o32,sysv) \
             variant=$(if $(BR2_ENABLE_DEBUG),debug,release) \
             link=$(if $(BR2_PREFER_STATIC_LIB),static,shared) \
             runtime-link=$(if $(BR2_PREFER_STATIC_LIB),static,shared)