package/freescale-imx/imx-gpu-viv: install Vendor ICDs file (Vivante.icd)
authorRomain Naour <romain.naour@smile.fr>
Wed, 23 Dec 2020 15:33:24 +0000 (16:33 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Dec 2020 17:32:45 +0000 (18:32 +0100)
Without this file, the clinfo binary provided by the package doesn't
detect the opencl support.

Fixes:
https://github.com/boundarydevices/buildroot-external-boundary/issues/5

Signed-off-by: Romain Naour <romain.naour@smile.fr>
Cc: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/freescale-imx/imx-gpu-viv/imx-gpu-viv.mk

index 0bb923a2f421b42a9d06279dac8ef089946643a5..a248da60690891fc6fbaaa52a521d59528dd439a 100644 (file)
@@ -108,6 +108,7 @@ define IMX_GPU_VIV_INSTALL_TARGET_CMDS
        $(IMX_GPU_VIV_INSTALL_EXAMPLES)
        $(IMX_GPU_VIV_INSTALL_GMEM_INFO)
        cp -a $(@D)/gpu-core/usr/lib $(TARGET_DIR)/usr
+       $(INSTALL) -D -m 0644 $(@D)/gpu-core/etc/Vivante.icd $(TARGET_DIR)/etc/OpenCL/vendors/Vivante.icd
        for lib in EGL GAL GLESv2 VDK; do \
                for f in $(TARGET_DIR)/usr/lib/lib$${lib}-*.so; do \
                        case $$f in \