foomatic-filters: make location of enscript very clear
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 4 Apr 2013 00:55:01 +0000 (00:55 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Apr 2013 20:57:30 +0000 (22:57 +0200)
Passing --with-file-converter=enscript isn't enough since the build
system will try the fallback options (a2ps, mpage, texttops) if it's not
found.
This has two bad effects: one of the tools leaking from the distribution
making foomatic-filters think everything will be the same on the target
(and failing when that's not the case), and failed builds when none is
found (enscript is installed in the target directory, the build system
doesn't look there).
So just avoid the test by stating explicitly where enscript will live in
the target. Fixes:
http://autobuild.buildroot.net/results/37ad3d2c5c35f00c644a2c572f1429bafa4b7cf4/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/foomatic-filters/foomatic-filters.mk

index ad7ab7a68de70f3f68b2daf99b5817c9f9f9ac4f..6e13486010c361c1986b46e5d8d1000be400b86b 100644 (file)
@@ -9,8 +9,8 @@ FOOMATIC_FILTERS_SITE = http://www.openprinting.org/download/foomatic
 FOOMATIC_FILTERS_LICENSE = GPLv2+
 FOOMATIC_FILTERS_LICENSE_FILES = COPYING
 FOOMATIC_FILTERS_DEPENDENCIES = cups libusb enscript
-
 FOOMATIC_FILTERS_CONF_OPT = --with-file-converter=enscript
+FOOMATIC_FILTERS_CONF_ENV = ac_cv_path_ENSCRIPT="/usr/bin/enscript"
 
 ifeq ($(BR2_PACKAGE_DBUS),y)
 FOOMATIC_FILTERS_CONF_OPT += --enable-dbus