package/gnupg2: add bzip2 optional dependency
authorRomain Naour <romain.naour@openwide.fr>
Tue, 23 Sep 2014 21:57:36 +0000 (23:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Oct 2014 20:45:21 +0000 (22:45 +0200)
This is to improve build reproducibility.

[Thomas: add --enable-bzip2 --with-bzip options.]

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gnupg2/gnupg2.mk

index 33b5bc0467175ae12e40ccf24927dba7a7b4da3d..b0e72976bb9bbd2e5fa14553afc6af005942ee61 100644 (file)
@@ -26,4 +26,11 @@ endef
 GNUPG2_POST_INSTALL_TARGET_HOOKS += GNUPG2_REMOVE_GPGV2
 endif
 
+ifeq ($(BR2_PACKAGE_BZIP2),y)
+GNUPG2_CONF_OPT += --enable-bzip2 --with-bzip2=$(STAGING_DIR)
+GNUPG2_DEPENDENCIES += bzip2
+else
+GNUPG2_CONF_OPT += --disable-bzip2
+endif
+
 $(eval $(autotools-package))