xapp_xdm: fix build with pkgconf 1.5.3
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 14 Dec 2018 15:30:39 +0000 (16:30 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 14 Dec 2018 20:25:09 +0000 (21:25 +0100)
Since the bump to 1.5.3, pkgconf prepends the sysroot to all absolute
paths found in the .pc file. This is correct when the paths refer to
something in STAGING_DIR (e.g. libdir, includedir), but not when it
refers to something used for the target.

xapp_xdm uses the appdefaultdir variable from xt.pc to decide where to
install things. Since DESTDIR is prepended to the install destination,
this will end up in the wrong location.

Until a better solution is found in pkgconf, pass the appdefaultdir to
use explicitly instead of relying on xt.pc.

Fixes:
 - http://autobuild.buildroot.org/results/08bcba7d7340f34dc66b5b2ab8fbcfbaee309e37

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/x11r7/xapp_xdm/xapp_xdm.mk

index 2c213a6bf06b2aec4a4a21ff0f55830d9b72fe75..422ee53b101c05ac49825156ebc4cce28e2e860f 100644 (file)
@@ -20,6 +20,7 @@ XAPP_XDM_DEPENDENCIES = \
        xlib_libXt \
        xorgproto
 XAPP_XDM_CONF_OPTS = \
+       --with-appdefaultdir=/usr/share/X11/app-defaults \
        --with-utmp-file=/var/adm/utmpx \
        --with-wtmp-file=/var/adm/wtmpx