package/pkg-autotools.mk: set --localstatedir=/var by default
authorJörg Krause <jkrause@posteo.de>
Fri, 17 Oct 2014 22:36:32 +0000 (00:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 18 Oct 2014 17:27:28 +0000 (19:27 +0200)
`localstatedir` is a common autoconf variable like prefix and sysconfdir. At
this time 25 autotools and one generic package uses this Makefile variable. 22
of the autotools packages use --localstatedir=/var, the remaining use custom
settings.

Setting `localstatedir` to /var is consistent with the Filesystem Hierarchy
Standard (FHS). So it's time to move it as a common definition in the
autotools infrastructure.

Signed-off-by: Jörg Krause <jkrause@posteo.de>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-autotools.mk

index 2c93dd96c3482b827b4ab93f70ab5dbcce51c1d4..3c5430f7d859f80d1b7055982efceb4620086b1b 100644 (file)
@@ -134,6 +134,7 @@ define $(2)_CONFIGURE_CMDS
                --prefix=/usr \
                --exec-prefix=/usr \
                --sysconfdir=/etc \
+               --localstatedir=/var \
                --program-prefix="" \
                --disable-gtk-doc \
                --disable-doc \
@@ -165,6 +166,7 @@ define $(2)_CONFIGURE_CMDS
                ./configure \
                --prefix="$$(HOST_DIR)/usr" \
                --sysconfdir="$$(HOST_DIR)/etc" \
+               --localstatedir="$$(HOST_DIR)/var" \
                --enable-shared --disable-static \
                --disable-gtk-doc \
                --disable-doc \