+Fix cross-compile
+
+Original patch for DRI
+http://git.buildroot.net/buildroot/commit/package/x11r7/xdriver_xf86-video-r128/xdriver_xf86-video-r128-cross-compile.patch?id=c0726391523da6a17ffa8e62681ffa0cc895da8e
+
+Signed-off-by: Paulius Zaleckas <paulius.zaleckas@gmail.com>
+(Added exa.h fix)
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
--- a/configure.ac 2008-06-23 10:39:28.000000000 -0400
+++ b/configure.ac 2008-06-23 10:40:46.000000000 -0400
@@ -85,14 +85,20 @@ sdkdir=$(pkg-config --variable=sdkdir xo
fi
AC_MSG_CHECKING([whether to include DRI support])
+@@ -121,7 +127,12 @@
+ AC_MSG_CHECKING([whether to enable EXA support])
+ if test "x$EXA" = xyes; then
+ AC_MSG_RESULT(yes)
+- AC_CHECK_FILE(${sdkdir}/exa.h, [have_exa_h="yes"], [have_exa_h="no"])
++ if test "$cross_compiling" = "no" ; then
++ AC_CHECK_FILE(${sdkdir}/exa.h,
++ [have_exa_h="yes"], [have_exa_h="no"])
++ else
++ have_exa_h="yes"
++ fi
+ else
+ AC_MSG_RESULT(no)
+ fi
#
################################################################################
-XDRIVER_XF86_VIDEO_R128_VERSION = fcee44e469b22934a04bd3ee19ed101aaa176a54
-XDRIVER_XF86_VIDEO_R128_SITE = git://anongit.freedesktop.org/xorg/driver/xf86-video-r128
+XDRIVER_XF86_VIDEO_R128_VERSION = 6.10.0
+XDRIVER_XF86_VIDEO_R128_SOURCE = xf86-video-r128-$(XDRIVER_XF86_VIDEO_R128_VERSION).tar.bz2
+XDRIVER_XF86_VIDEO_R128_SITE = http://xorg.freedesktop.org/releases/individual/driver
XDRIVER_XF86_VIDEO_R128_LICENSE = MIT
XDRIVER_XF86_VIDEO_R128_LICENSE_FILES = COPYING
XDRIVER_XF86_VIDEO_R128_AUTORECONF = YES