perl-class-std-fast: new package
authorChristopher McCrory <chrismcc@gmail.com>
Sat, 11 Aug 2018 18:27:36 +0000 (11:27 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 13 Aug 2018 10:05:12 +0000 (12:05 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-class-std-fast/Config.in [new file with mode: 0644]
package/perl-class-std-fast/perl-class-std-fast.hash [new file with mode: 0644]
package/perl-class-std-fast/perl-class-std-fast.mk [new file with mode: 0644]

index 4379b24da14b9018dabd9107c236b747a02fd98a..46c0f06637ce988340826af71bcd799b7eba9bc0 100644 (file)
@@ -484,6 +484,7 @@ N:  Christopher McCrory <chrismcc@gmail.com>
 F:     package/perl-appconfig/
 F:     package/perl-astro-suntime/
 F:     package/perl-class-std/
+F:     package/perl-class-std-fast/
 F:     package/perl-data-uuid/
 F:     package/perl-date-manip/
 F:     package/perl-dbi/
index a50eb2d5613ee098812e41a1568158bfe9cb0ee4..858b781251e3efdf5b988ae38dba29ae923afb45 100644 (file)
@@ -668,6 +668,7 @@ menu "Perl libraries/modules"
        source "package/perl-appconfig/Config.in"
        source "package/perl-astro-suntime/Config.in"
        source "package/perl-class-std/Config.in"
+       source "package/perl-class-std-fast/Config.in"
        source "package/perl-convert-asn1/Config.in"
        source "package/perl-crypt-blowfish/Config.in"
        source "package/perl-crypt-cbc/Config.in"
diff --git a/package/perl-class-std-fast/Config.in b/package/perl-class-std-fast/Config.in
new file mode 100644 (file)
index 0000000..10b1e0d
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PERL_CLASS_STD_FAST
+       bool "perl-class-std-fast"
+       select BR2_PACKAGE_PERL_CLASS_STD
+       help
+         faster but less secure than Class::Std
+
+         https://metacpan.org/release/Class-Std-Fast
diff --git a/package/perl-class-std-fast/perl-class-std-fast.hash b/package/perl-class-std-fast/perl-class-std-fast.hash
new file mode 100644 (file)
index 0000000..07e830a
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    d06d084cb84f295b0aabf2eee78ef746 Class-Std-Fast-v0.0.8.tar.gz
+sha256 1bd43763c6a373183097a30e787f5d6713b0db27511c52d533266b59d2cfa780 Class-Std-Fast-v0.0.8.tar.gz
+
+# computed by scancpan
+sha256 aa1ab90c498aee078076e9a1f83e5f14bbfd841509582795ab5a9571428c0c38 README
diff --git a/package/perl-class-std-fast/perl-class-std-fast.mk b/package/perl-class-std-fast/perl-class-std-fast.mk
new file mode 100644 (file)
index 0000000..7c00862
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-class-std-fast
+#
+################################################################################
+
+PERL_CLASS_STD_FAST_VERSION = v0.0.8
+PERL_CLASS_STD_FAST_SOURCE = Class-Std-Fast-$(PERL_CLASS_STD_FAST_VERSION).tar.gz
+PERL_CLASS_STD_FAST_SITE = $(BR2_CPAN_MIRROR)/authors/id/A/AC/ACID
+PERL_CLASS_STD_FAST_DEPENDENCIES = perl-class-std
+PERL_CLASS_STD_FAST_LICENSE = Artistic or GPL-1.0+
+PERL_CLASS_STD_FAST_LICENSE_FILES = README
+
+$(eval $(perl-package))