package/snmppp: fix SNMPv3 with gcc <= 5
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 26 Jul 2020 21:29:06 +0000 (23:29 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 27 Jul 2020 06:43:26 +0000 (08:43 +0200)
Fixes:
 - http://autobuild.buildroot.org/results/bfe3faefc007f2e746c9f0af9b7d0926bb72dc9e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/snmppp/Config.in
package/snmppp/snmppp.mk

index 8d284673bc4ce28dec8d710d6795a12de8b85af9..de1a09ca4b4f80b39463d13aa0e5abbfefd58dda 100644 (file)
@@ -21,10 +21,14 @@ config BR2_PACKAGE_SNMPPP_LOGGING
 config BR2_PACKAGE_SNMPPP_SNMPV3
        bool "enable SNMPv3"
        default y
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
        select BR2_PACKAGE_OPENSSL
        help
          Enable optional support for SNMP++. This selects OpenSSL.
 
+comment "SNMPv3 needs a toolchain w/ gcc >= 4.8"
+       depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
+
 endif
 
 comment "snmp++ needs a toolchain w/ threads, C++, dynamic library"
index 8090a03818eb86b51c7b491cb0b81fdb2398ae99..270c41fc4b38f6d457af1622538709e680ca340e 100644 (file)
@@ -14,6 +14,7 @@ SNMPPP_LICENSE = SNMP++
 SNMPPP_LICENSE_FILES = src/v3.cpp
 
 ifeq ($(BR2_PACKAGE_SNMPPP_SNMPV3),y)
+SNMPPP_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
 SNMPPP_CONF_OPTS += --enable-snmpv3
 SNMPPP_DEPENDENCIES += openssl
 else