package/open62541: bump version to 1.2.2
authorScott Fan <fancp2007@gmail.com>
Mon, 26 Jul 2021 05:01:51 +0000 (13:01 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 26 Jul 2021 21:42:23 +0000 (23:42 +0200)
Signed-off-by: Scott Fan <fancp2007@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/open62541/0002-arch-posix-CMakeLists.txt-fix-build-without-threads.patch
package/open62541/open62541.hash
package/open62541/open62541.mk

index 94ee76ad92fa7b3a49456f9992af9208a0e2b8ba..bdf3608041aed0c19d7f882d0b21fa0a946c354d 100644 (file)
@@ -29,7 +29,7 @@ index bb24757c..a53c9f2c 100644
            ua_architecture_append_to_library(m)
 -          #TODO - Error on first make run if pthread is included conditional?
 -          ua_architecture_append_to_library(pthread)
-           if(UA_ENABLE_MULTITHREADING OR UA_BUILD_UNIT_TESTS)
+           if(UA_MULTITHREADING OR UA_BUILD_UNIT_TESTS)
              ua_architecture_append_to_library(pthread)
            endif()
 -- 
index 3da8c8f5fb9b10c52dfaa4d4bbd930f94bb58149..5aa340ac1857ffb5d3ea0e305467ba1f51e83978 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256  36273793e5247586fadaa73c0edad89be610100cbc839d1fb5f567f20c3cbc44  open62541-1.0-br1.tar.gz
+sha256  c59c85b519a18350f5014b6e7b7545ee144ceeb15094e75b0b7ecec7dce43dd0  open62541-v1.2.2-br1.tar.gz
 sha256  fab3dd6bdab226f1c08630b1dd917e11fcb4ec5e1e020e2c16f83a0a13863e85  LICENSE
index 3f751968179844fc82153ed790c17f8e853836b0..9c6468d443181bb8acb2437338c6d47dcada854d 100644 (file)
@@ -4,8 +4,7 @@
 #
 ################################################################################
 
-OPEN62541_VERSION = 1.0
-OPEN62541_DL_VERSION = v$(OPEN62541_VERSION)
+OPEN62541_VERSION = v1.2.2
 OPEN62541_SITE_METHOD = git
 OPEN62541_SITE = git://github.com/open62541/open62541.git
 OPEN62541_GIT_SUBMODULES = YES
@@ -19,7 +18,7 @@ OPEN62541_LICENSE_FILES = LICENSE
 OPEN62541_CONF_OPTS = \
        -DCMAKE_BUILD_TYPE=Release \
        -DGIT_EXECUTABLE=NO \
-       -DOPEN62541_VERSION=v$(OPEN62541_VERSION) \
+       -DOPEN62541_VERSION=$(OPEN62541_VERSION) \
        -DUA_ENABLE_HARDENING=OFF
 
 ifeq ($(BR2_PACKAGE_OPEN62541_UA_NAMESPACE_ZERO_MINIMAL),y)