package/python-pytest: bump to version 6.1.2
authorMarcin Niestroj <m.niestroj@grinn-global.com>
Sat, 12 Dec 2020 15:27:08 +0000 (16:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 13 Dec 2020 09:21:28 +0000 (10:21 +0100)
python-more-itertools was removed as dependency starting from
[1] (release 6.1.0).

XML module is now a hard requirement.

[1] https://github.com/pytest-dev/pytest/commit/96a48f0c66ebe1ec2305c21390a3f6c059760af5

Signed-off-by: Marcin Niestroj <m.niestroj@grinn-global.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-pytest/Config.in
package/python-pytest/python-pytest.hash
package/python-pytest/python-pytest.mk

index ad57547a1bba4bab0f8130ef56febd3eb24aca70..ebbaeeea585b9c08fdd47f54329fa0e8cf10bd95 100644 (file)
@@ -3,11 +3,11 @@ config BR2_PACKAGE_PYTHON_PYTEST
        depends on BR2_PACKAGE_PYTHON3
        select BR2_PACKAGE_PYTHON_ATTRS # runtime
        select BR2_PACKAGE_PYTHON_INICONFIG # runtime
-       select BR2_PACKAGE_PYTHON_MORE_ITERTOOLS # runtime
        select BR2_PACKAGE_PYTHON_PACKAGING # runtime
        select BR2_PACKAGE_PYTHON_PLUGGY # runtime
        select BR2_PACKAGE_PYTHON_PY # runtime
        select BR2_PACKAGE_PYTHON_TOML # runtime
+       select BR2_PACKAGE_PYTHON3_PYEXPAT # runtime
        help
          pytest is a framework that makes building simple and scalable
          tests easy. Tests are expressive and readable—no boilerplate
index 6f3532a5906d496b98afcedeb1b709b4be393ab5..8c2a85c9223df5d5a08301510c85e3a68e37fa7f 100644 (file)
@@ -1,5 +1,5 @@
 # md5, sha256 from https://pypi.org/pypi/pytest/json
-md5    c3e7c811b2b74c60bb5fb951229ebce9  pytest-6.0.1.tar.gz
-sha256 85228d75db9f45e06e57ef9bf4429267f81ac7c0d742cc9ed63d09886a9fe6f4  pytest-6.0.1.tar.gz
+md5    91a421ffffe3310096b4273b2fa13819  pytest-6.1.2.tar.gz
+sha256 c0a7e94a8cdbc5422a51ccdad8e6f1024795939cc89159a0ae7f0b316ad3823e  pytest-6.1.2.tar.gz
 # Locally computer sha256
 sha256 7898b9b164d4f93fd9a562fd0f592935518b48c4745303964110eb7f7fe64faf  LICENSE
index c17d579f8c82c9b3baad39ea3e5a4519fcf22689..d47ec0f4308fdbde09aa947adecd5b9017d43e78 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-PYTHON_PYTEST_VERSION = 6.0.1
+PYTHON_PYTEST_VERSION = 6.1.2
 PYTHON_PYTEST_SOURCE = pytest-$(PYTHON_PYTEST_VERSION).tar.gz
-PYTHON_PYTEST_SITE = https://files.pythonhosted.org/packages/20/4c/d7b19b8661be78461fff0392e33943784340424921578fe1bf300ef59831
+PYTHON_PYTEST_SITE = https://files.pythonhosted.org/packages/d4/df/bd7c25c4fe809a17315b3fc9878edf48d31dde7b431b6836848b063c0428
 PYTHON_PYTEST_SETUP_TYPE = setuptools
 PYTHON_PYTEST_LICENSE = MIT
 PYTHON_PYTEST_LICENSE_FILES = LICENSE