Makefile.autotools.in: make MESSAGE output stand out
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 7 Nov 2008 08:56:02 +0000 (08:56 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 7 Nov 2008 08:56:02 +0000 (08:56 -0000)
The following patch makes the MESSAGE Macro in Makefile.autotools.in
work.

I think it was originally intended to print the messages in bold type
but it doesn't appear to work correctly. This patch should work on all
platforms.

Signed-off-by: H Hartley Sweeten <hsweeten@visionengravers.com>
(Fixed to not continously call tput)

package/Makefile.autotools.in

index 6d62c047a5e5b5b1a7c02555aabf8e56f9e1130c..2e5d16606c8ddbc83c10316d277649814cd568f0 100644 (file)
@@ -114,8 +114,8 @@ INFLATE.tar = cat
 
 # MESSAGE Macro -- display a message in bold type
 MESSAGE = @echo "$(TERM_BOLD)>>> $($(PKG)_NAME) $($(PKG)_VERSION) $(1)$(TERM_RESET)"
-TERM_BOLD = #$(shell tput bold)
-TERM_RESET = #$(shell tput rmso)
+TERM_BOLD := $(shell tput smso)
+TERM_RESET := $(shell tput rmso)
 
 # Utility programs used to build packages
 TAR ?= tar