cryptsetup: fix build with old host kernel headers
authorBaruch Siach <baruch@tkos.co.il>
Tue, 7 Aug 2018 11:04:48 +0000 (14:04 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 18 Aug 2018 09:23:42 +0000 (11:23 +0200)
By default cryptsetup configure fails when the if_alg.h kernel header is
not available. Kernels older than 2.6.38, like the one in RHEL 6 hosts,
do not provide this header. Since we don't need the kernel crypto
feature for host tools, just disable this feature to allow successful
completion of the configure script.

While at it, fix a typo in the --with-crypto_backend option (hyphen ->
underscore).

Should fix:
http://autobuild.buildroot.net/results/ffd/ffda2579b215b53161025b7bc703091cb30ef95d/
http://autobuild.buildroot.net/results/c48/c48015f76b13fec38f650f66824e7b986eb28572/
http://autobuild.buildroot.net/results/be6/be621f71bf9da8719bf7fc943eccc9b4dc2cc43e/

Cc: Martin Hicks <mort@bork.org>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/cryptsetup/cryptsetup.mk

index d5ab022b7779063c861e591aa89bb070cca9755d..d81aa7b341a5cffc84e5fb2aae91608a8152edd8 100644 (file)
@@ -36,7 +36,8 @@ HOST_CRYPTSETUP_DEPENDENCIES = \
        host-json-c \
        host-openssl
 
-HOST_CRYPTSETUP_CONF_OPTS = --with-crypto-backend=openssl
+HOST_CRYPTSETUP_CONF_OPTS = --with-crypto_backend=openssl \
+       --disable-kernel_crypto
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))