lcdproc: use ac_cv_mtab_file
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 27 Oct 2018 21:01:14 +0000 (23:01 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 28 Oct 2018 07:14:28 +0000 (08:14 +0100)
Set ac_cv_mtab_file to /etc/mtab otherwise build will fail if no mtab,
mnttab or fstab is found in /etc (on host)

Fixes:
 - http://autobuild.buildroot.org/results/efaf2833d674c7e366c59f367f0b83c7f88546bb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/lcdproc/lcdproc.mk

index e5b6172b15a48c31cd3e3a5cc2516d8f477ef743..96e59da409ef8a368a02b24d8d858f432e40fe2b 100644 (file)
@@ -18,7 +18,9 @@ endif
 
 LCDPROC_DEPENDENCIES = freetype ncurses zlib
 
-LCDPROC_CONF_ENV += ac_cv_path_FT2_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
+LCDPROC_CONF_ENV += \
+       ac_cv_mtab_file=/etc/mtab \
+       ac_cv_path_FT2_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
 
 ifeq ($(BR2_PACKAGE_LIBPNG),y)
 LCDPROC_DEPENDENCIES += libpng