ti-gfx: systemd support
authorAlex Suykov <alex.suykov@gmail.com>
Sat, 23 May 2015 10:07:32 +0000 (13:07 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 22:19:58 +0000 (00:19 +0200)
The startup script too complex to embed it completely into the
.service file, so it is left as a standalone script.

[Thomas:
 - use relative path for the symbolic link
 - slightly tweak the service Description string]

Signed-off-by: Alex Suykov <alex.suykov@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ti-gfx/ti-gfx.mk
package/ti-gfx/ti-gfx.service [new file with mode: 0644]

index 061e9fe6fa8087d14ec0c247c25031cf087d476a..5339387c985398c32d56959548425c2f9c19b873 100644 (file)
@@ -190,6 +190,16 @@ define TI_GFX_INSTALL_INIT_SYSV
                $(TARGET_DIR)/etc/init.d/S80ti-gfx
 endef
 
+define TI_GFX_INSTALL_INIT_SYSTEMD
+       $(INSTALL) -D -m 755 package/ti-gfx/S80ti-gfx \
+               $(TARGET_DIR)/usr/lib/systemd/scripts/ti-gfx
+       $(INSTALL) -D -m 644 package/ti-gfx/ti-gfx.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/ti-gfx.service
+       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+       ln -sf ../../../../usr/lib/systemd/system/ti-gfx.service \
+               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/ti-gfx.service
+endef
+
 define TI_GFX_INSTALL_TARGET_CMDS
        $(TI_GFX_INSTALL_KM_CMDS)
        $(TI_GFX_INSTALL_BINS_CMDS)
diff --git a/package/ti-gfx/ti-gfx.service b/package/ti-gfx/ti-gfx.service
new file mode 100644 (file)
index 0000000..432dba2
--- /dev/null
@@ -0,0 +1,11 @@
+[Unit]
+Description=TI graphics driver
+
+[Service]
+Type=oneshot
+ExecStart=/usr/lib/systemd/scripts/ti-gfx start
+ExecStop=/usr/lib/systemd/scripts/ti-gfx stop
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target