dropbear: add extra build customization options
authorFloris Bos <bos@je-eigen-domein.nl>
Wed, 4 Feb 2015 18:33:29 +0000 (19:33 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 7 Feb 2015 11:52:25 +0000 (12:52 +0100)
v2: only offer option to disable building SSH client.
    do not offer options to disable password authentication and TCP forwarding.

Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dropbear/Config.in
package/dropbear/dropbear.mk

index 68c3b71aa931fc2c2d8e157c12876dc2446d8526..c14c6544c3e494fe7093a8831b14643ffbeaaffa 100644 (file)
@@ -8,6 +8,16 @@ config BR2_PACKAGE_DROPBEAR
 
 if BR2_PACKAGE_DROPBEAR
 
+config BR2_PACKAGE_DROPBEAR_CLIENT
+       bool "client programs"
+       default y
+       help
+         Provides the programs: dbclient, ssh
+
+         Note that the following programs are also used server-side
+         and are therefore always build regardless this setting:
+         dropbear, dropbearkey, dropbearconvert, scp
+
 config BR2_PACKAGE_DROPBEAR_DISABLE_REVERSEDNS
        bool "disable reverse DNS lookups"
        help
index 6e020c2c0bf788b288fbfd3d657816b06bfec8ff..e063b10a46a3547233345b8567895b4d5204b9e8 100644 (file)
@@ -7,13 +7,20 @@
 DROPBEAR_VERSION = 2015.67
 DROPBEAR_SITE = http://matt.ucc.asn.au/dropbear/releases
 DROPBEAR_SOURCE = dropbear-$(DROPBEAR_VERSION).tar.bz2
-DROPBEAR_TARGET_BINS = dbclient dropbearkey dropbearconvert scp ssh
-DROPBEAR_MAKE = \
-       $(MAKE) MULTI=1 SCPPROGRESS=1 \
-       PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp"
-
 DROPBEAR_LICENSE = MIT, BSD-2c-like, BSD-2c
 DROPBEAR_LICENSE_FILES = LICENSE
+DROPBEAR_TARGET_BINS = dropbearkey dropbearconvert scp
+DROPBEAR_PROGRAMS = dropbear $(DROPBEAR_TARGET_BINS)
+
+ifeq ($(BR2_PACKAGE_DROPBEAR_CLIENT),y)
+# Build dbclient, and create a convenience symlink named ssh
+DROPBEAR_PROGRAMS += dbclient
+DROPBEAR_TARGET_BINS += dbclient ssh
+endif
+
+DROPBEAR_MAKE = \
+       $(MAKE) MULTI=1 SCPPROGRESS=1 \
+       PROGRAMS="$(DROPBEAR_PROGRAMS)"
 
 ifeq ($(BR2_STATIC_LIBS),y)
 DROPBEAR_MAKE += STATIC=1