triggerhappy: use target pkg-config
authorBaruch Siach <baruch@tkos.co.il>
Mon, 11 Jun 2018 18:24:47 +0000 (21:24 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 11 Jun 2018 19:37:36 +0000 (21:37 +0200)
triggerhappy uses pkg-config to detect the systemd library. Make sure it
uses the target pkg-config, not the host one.

Fixes build failure when the host has systemd pkg-config files:

.../host/bin/arm-linux-gcc -static  th-cmd.o cmdsocket.o  -lsystemd -o th-cmd
.../host/opt/ext-toolchain/bin/../lib/gcc/arm-buildroot-linux-uclibcgnueabi/6.4.0/../../../../arm-buildroot-linux-uclibcgnueabi/bin/ld: cannot find -lsystemd

Cc: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/triggerhappy/triggerhappy.mk

index 9f74c486f10ec06af527fe24ccc21a2384d2e26b..4c39ab5e5d4e7e79ebdef09631fa488085349782 100644 (file)
@@ -8,9 +8,11 @@ TRIGGERHAPPY_VERSION = b822888066129350e51ad79f1cf307fa38dae4f7
 TRIGGERHAPPY_SITE = $(call github,wertarbyte,triggerhappy,$(TRIGGERHAPPY_VERSION))
 TRIGGERHAPPY_LICENSE = GPL-3.0+
 TRIGGERHAPPY_LICENSE_FILES = COPYING
+TRIGGERHAPPY_DEPENDENCIES = host-pkgconf
 
 define TRIGGERHAPPY_BUILD_CMDS
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) thd th-cmd
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) PKGCONFIG="$(PKG_CONFIG_HOST_BINARY)" \
+               -C $(@D) thd th-cmd
 endef
 
 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)