wine: Add OpenAL dependency
authorAndré Hentschel <nerv@dawncrow.de>
Sun, 13 Dec 2015 23:57:05 +0000 (00:57 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Dec 2015 21:57:10 +0000 (22:57 +0100)
Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wine/wine.mk

index 1a1fea045af322185b7069e3063ad65686608fb1..98958ef03c03652e494d38cd2170411cd00f0ee4 100644 (file)
@@ -25,7 +25,6 @@ WINE_CONF_OPTS = \
        --without-gphoto \
        --without-gsm \
        --without-hal \
-       --without-openal \
        --without-opencl \
        --without-oss
 
@@ -163,6 +162,13 @@ else
 WINE_CONF_OPTS += --without-curses
 endif
 
+ifeq ($(BR2_PACKAGE_OPENAL),y)
+WINE_CONF_OPTS += --with-openal
+WINE_DEPENDENCIES += openal
+else
+WINE_CONF_OPTS += --without-openal
+endif
+
 ifeq ($(BR2_PACKAGE_OPENLDAP),y)
 WINE_CONF_OPTS += --with-ldap
 WINE_DEPENDENCIES += openldap