package/cryptopp: Backport gcc compatibility patch
authorJulian Scheel <julian@jusst.de>
Mon, 25 Apr 2016 08:09:29 +0000 (10:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 28 Apr 2016 11:50:03 +0000 (13:50 +0200)
Import patch from cryptopp upstream which fixes the gcc version checks
for using attribute deprecated with messages. Fixes build with host
gcc versions < 4.5.

Signed-off-by: Julian Scheel <julian@jusst.de>
[Thomas:
 - directly use the patch from upstream through <pkg>_PATCH rather
   than storing it in package/cryptopp/, as it helps avoiding
   line-endings problems: upstream has the source code with DOS line
   endings.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cryptopp/cryptopp.hash
package/cryptopp/cryptopp.mk

index 3af7183c5df6bb28541e2a17c3d11e76a2a36d39..bf59c0451d6b65c2a711e0fa1d795b2fb2d30037 100644 (file)
@@ -1,2 +1,3 @@
 # Locally computed
 sha256  9390670a14170dd0f48a6b6b06f74269ef4b056d4718a1a329f6f6069dc957c9  cryptopp563.zip
+sha256  74b88c2caf7cf843bdc74d3331adaf83e516167cc8eebe66a79612189549cfa4  f707b9ef1688d4429ca6239cf2dc236440974681.patch
index 887557dbcec85aa9efa1cdbace9483f6bd3c3ff6..df07cf607fd3dea8a2c5d0c54454add50a9a3851 100644 (file)
@@ -7,6 +7,8 @@
 CRYPTOPP_VERSION = 5.6.3
 CRYPTOPP_SOURCE = cryptopp$(subst .,,$(CRYPTOPP_VERSION)).zip
 CRYPTOPP_SITE = http://cryptopp.com/
+# Upstream patch needed to fix the build with gcc < 4.5
+CRYPTOPP_PATCH = https://github.com/weidai11/cryptopp/commit/f707b9ef1688d4429ca6239cf2dc236440974681.patch
 CRYPTOPP_LICENSE = Boost-v1.0
 CRYPTOPP_LICENSE_FILES = License.txt
 CRYPTOPP_INSTALL_STAGING = YES