package/hiawatha: enable optional xslt support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 29 May 2020 17:58:56 +0000 (19:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 29 May 2020 20:48:51 +0000 (22:48 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/hiawatha/hiawatha.mk

index eefd0f6f893ba83810a5825380931b448b03218d..28fd286ea88b7f697c9de8fa776f30da5f9d031a 100644 (file)
@@ -17,9 +17,15 @@ else
 HIAWATHA_CONF_OPTS += -DENABLE_TLS=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXSLT),y)
+HIAWATHA_CONF_OPTS += -DENABLE_XSLT=ON
+HIAWATHA_DEPENDENCIES += libxslt
+else
+HIAWATHA_CONF_OPTS += -DENABLE_XSLT=OFF
+endif
+
 HIAWATHA_CONF_OPTS += \
        -DENABLE_TOOLKIT=OFF \
-       -DENABLE_XSLT=OFF \
        -DCONFIG_DIR=/etc/hiawatha \
        -DLOG_DIR=/var/log \
        -DPID_DIR=/var/run \