nftables: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 21:07:17 +0000 (23:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:28:46 +0000 (01:28 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nftables/Config.in
package/nftables/nftables.mk

index d0a1b8927747e8bc10cceeda1687917e6e4a7466..7c0abe0daf4cb4e57d4853941f8123fed18604ff 100644 (file)
@@ -5,7 +5,6 @@ config BR2_PACKAGE_NFTABLES
        select BR2_PACKAGE_GMP
        select BR2_PACKAGE_LIBMNL
        select BR2_PACKAGE_LIBNFTNL
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
        help
          nftables is the project that aims to replace the existing
          {ip,ip6,arp,eb}tables framework.
index 7263ec70b96751224dab64323124268757b11834..d1e605565e8c32a1ecb69ccd44731f43d3bd3cfe 100644 (file)
@@ -8,7 +8,7 @@ NFTABLES_VERSION = 0.7
 NFTABLES_SOURCE = nftables-$(NFTABLES_VERSION).tar.bz2
 NFTABLES_SITE = http://www.netfilter.org/projects/nftables/files
 NFTABLES_DEPENDENCIES = gmp libmnl libnftnl host-bison host-flex \
-       host-pkgconf $(if $(BR2_NEEDS_GETTEXT),gettext)
+       host-pkgconf $(TARGET_NLS_DEPENDENCIES)
 NFTABLES_LICENSE = GPL-2.0
 NFTABLES_LICENSE_FILES = COPYING