package/opencv: bump version to 2.4.13.2
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 19 Apr 2017 10:11:41 +0000 (12:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 2 May 2017 20:50:41 +0000 (22:50 +0200)
Removed patch applied upstream:
https://github.com/opencv/opencv/commit/c7045184ce220a04796d8e9072ac42d2d362dc71

Renumbered remaining patches.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/opencv/0003-CMakeLists.txt-Do-not-add-libdl-to-LINKER_LIBS-for-s.patch [new file with mode: 0644]
package/opencv/0003-types_c.h-Fix-compiling-VFP-assembler-code.patch [deleted file]
package/opencv/0004-CMakeLists.txt-Do-not-add-libdl-to-LINKER_LIBS-for-s.patch [deleted file]
package/opencv/opencv.hash
package/opencv/opencv.mk

diff --git a/package/opencv/0003-CMakeLists.txt-Do-not-add-libdl-to-LINKER_LIBS-for-s.patch b/package/opencv/0003-CMakeLists.txt-Do-not-add-libdl-to-LINKER_LIBS-for-s.patch
new file mode 100644 (file)
index 0000000..6d63411
--- /dev/null
@@ -0,0 +1,39 @@
+From 22e03ef8a9e3adcbc6b2f16c3cc98e4e14443eed Mon Sep 17 00:00:00 2001
+From: Bernd Kuhls <bernd.kuhls@t-online.de>
+Date: Sat, 24 Sep 2016 17:51:22 +0200
+Subject: [PATCH 1/1] CMakeLists.txt: Do not add libdl to LINKER_LIBS for
+ static builds
+
+Without this patch -ldl is present in opencv.pc which breaks OpenCV
+detection by ffmpeg, detected by buildroot autobuilders:
+
+http://autobuild.buildroot.net/results/765/7657e01481995a4f0d725467e935a83928a59a04//ffmpeg-3.1.3/config.log
+
+/home/peko/autobuild/instance-1/output/host/opt/ext-toolchain/bin/../lib/gcc/arm-buildroot-linux-uclibcgnueabi/4.9.4/../../../../arm-buildroot-linux-uclibcgnueabi/bin/ld: cannot find -ldl
+
+Patch sent upstream: https://github.com/opencv/opencv/pull/7337
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+---
+ CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 007b80d..99b047d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -457,7 +457,10 @@ if(UNIX)
+     elseif(${CMAKE_SYSTEM_NAME} MATCHES "QNX")
+       set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} m)
+     else()
+-      set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} dl m pthread rt)
++      if(BUILD_SHARED_LIBS)
++        set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} dl)
++      endif()
++      set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} m pthread rt)
+     endif()
+   else()
+     set(HAVE_LIBPTHREAD YES)
+-- 
+2.9.3
+
diff --git a/package/opencv/0003-types_c.h-Fix-compiling-VFP-assembler-code.patch b/package/opencv/0003-types_c.h-Fix-compiling-VFP-assembler-code.patch
deleted file mode 100644 (file)
index 85a23a0..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-From 18c868c47307b786d1bea729dccaad7f8d696cb7 Mon Sep 17 00:00:00 2001
-From: Bernd Kuhls <bernd.kuhls@t-online.de>
-Date: Tue, 6 Sep 2016 11:49:00 +0200
-Subject: [PATCH 1/1] types_c.h: Fix compiling VFP assembler code
-
-Replace asm by __asm__ according to
-https://gcc.gnu.org/onlinedocs/gcc/Alternate-Keywords.html#Alternate-Keywords
-as suggested by Arnout Vandecappelle:
-http://lists.busybox.net/pipermail/buildroot/2016-September/171491.html
-
-to fix build errors in ffmpeg with opencv2 support detected by
-buildroot autobuilders:
-http://autobuild.buildroot.net/results/c32/c32a21240a9933796ee850349a62ff3c2314f25c/build-end.log
-
-Patch sent upstream: https://github.com/opencv/opencv/pull/7242
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
----
- modules/core/include/opencv2/core/types_c.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/modules/core/include/opencv2/core/types_c.h b/modules/core/include/opencv2/core/types_c.h
-index c21cd2c..771715d 100644
---- a/modules/core/include/opencv2/core/types_c.h
-+++ b/modules/core/include/opencv2/core/types_c.h
-@@ -318,7 +318,7 @@ enum {
-     int res; \
-     float temp; \
-     (void)temp; \
--    asm(_asm_string : [res] "=r" (res), [temp] "=w" (temp) : [value] "w" (_value)); \
-+    __asm__(_asm_string : [res] "=r" (res), [temp] "=w" (temp) : [value] "w" (_value)); \
-     return res;
- // 2. version for double
- #ifdef __clang__
--- 
-2.9.3
-
diff --git a/package/opencv/0004-CMakeLists.txt-Do-not-add-libdl-to-LINKER_LIBS-for-s.patch b/package/opencv/0004-CMakeLists.txt-Do-not-add-libdl-to-LINKER_LIBS-for-s.patch
deleted file mode 100644 (file)
index 6d63411..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-From 22e03ef8a9e3adcbc6b2f16c3cc98e4e14443eed Mon Sep 17 00:00:00 2001
-From: Bernd Kuhls <bernd.kuhls@t-online.de>
-Date: Sat, 24 Sep 2016 17:51:22 +0200
-Subject: [PATCH 1/1] CMakeLists.txt: Do not add libdl to LINKER_LIBS for
- static builds
-
-Without this patch -ldl is present in opencv.pc which breaks OpenCV
-detection by ffmpeg, detected by buildroot autobuilders:
-
-http://autobuild.buildroot.net/results/765/7657e01481995a4f0d725467e935a83928a59a04//ffmpeg-3.1.3/config.log
-
-/home/peko/autobuild/instance-1/output/host/opt/ext-toolchain/bin/../lib/gcc/arm-buildroot-linux-uclibcgnueabi/4.9.4/../../../../arm-buildroot-linux-uclibcgnueabi/bin/ld: cannot find -ldl
-
-Patch sent upstream: https://github.com/opencv/opencv/pull/7337
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
----
- CMakeLists.txt | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 007b80d..99b047d 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -457,7 +457,10 @@ if(UNIX)
-     elseif(${CMAKE_SYSTEM_NAME} MATCHES "QNX")
-       set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} m)
-     else()
--      set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} dl m pthread rt)
-+      if(BUILD_SHARED_LIBS)
-+        set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} dl)
-+      endif()
-+      set(OPENCV_LINKER_LIBS ${OPENCV_LINKER_LIBS} m pthread rt)
-     endif()
-   else()
-     set(HAVE_LIBPTHREAD YES)
--- 
-2.9.3
-
index 9686cb287dd54b4fde0af09d4abe56cea42d6325..2c1842bd5668b6fb313f3bfb258fe8923fa75ecc 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 94ebcca61c30034d5fb16feab8ec12c8a868f5162d20a9f0396f0f5f6d8bbbff  opencv-2.4.13.tar.gz
+sha256 4b00c110e6c54943cbbb7cf0d35c5bc148133ab2095ee4aaa0ac0a4f67c58080  opencv-2.4.13.2.tar.gz
index 4ae550e8c67923f14abdbad6678865da09552382..ff5ab02b16ff3a94dbb791d550ef8917b9892b09 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-OPENCV_VERSION = 2.4.13
+OPENCV_VERSION = 2.4.13.2
 OPENCV_SITE = $(call github,itseez,opencv,$(OPENCV_VERSION))
 OPENCV_INSTALL_STAGING = YES
 OPENCV_LICENSE = BSD-3-Clause