at-spi2-atk: new package
authorJoseph Kogut <joseph.kogut@gmail.com>
Fri, 22 Jun 2018 00:33:36 +0000 (17:33 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 25 Jun 2018 21:06:58 +0000 (23:06 +0200)
Signed-off-by: Joseph Kogut <joseph.kogut@gmail.com>
[Thomas: drop unneeded AT_SPI2_ATK_INSTALL_STAGING_OPTS variable.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/at-spi2-atk/Config.in [new file with mode: 0644]
package/at-spi2-atk/at-spi2-atk.hash [new file with mode: 0644]
package/at-spi2-atk/at-spi2-atk.mk [new file with mode: 0644]

index b3148a0270fe705dc88c7990dee3da63d709ee6a..27e24896fb31bd8db65b864271abbcc0e28eec8b 100644 (file)
@@ -975,6 +975,7 @@ F:  board/qemu/ppc64le-pseries/
 F:     configs/qemu_ppc64le_pseries_defconfig
 
 N:     Joseph Kogut <joseph.kogut@gmail.com>
+F:     package/at-spi2-atk/
 F:     package/at-spi2-core/
 F:     package/gconf/
 F:     package/libnss/
index 63db543d871fb1048b806f891eb94de7a0bc4b4c..13b34aed0456c1cdd0f547eda9ca5c7d3535a908 100644 (file)
@@ -1131,6 +1131,7 @@ endmenu
 
 menu "Graphics"
        source "package/assimp/Config.in"
+       source "package/at-spi2-atk/Config.in"
        source "package/at-spi2-core/Config.in"
        source "package/atk/Config.in"
        source "package/atkmm/Config.in"
diff --git a/package/at-spi2-atk/Config.in b/package/at-spi2-atk/Config.in
new file mode 100644 (file)
index 0000000..9a7cfde
--- /dev/null
@@ -0,0 +1,22 @@
+config BR2_PACKAGE_AT_SPI2_ATK
+       bool "at-spi2-atk"
+       depends on BR2_PACKAGE_XORG7 # at-spi2-core
+       depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
+       depends on BR2_USE_MMU # glib2
+       depends on BR2_USE_WCHAR # glib2
+       select BR2_PACKAGE_ATK
+       select BR2_PACKAGE_AT_SPI2_CORE
+       select BR2_PACKAGE_LIBGLIB2
+       help
+         The At-Spi2 Atk package contains a library that bridges
+         ATK to At-Spi2 D-Bus service.
+
+         https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/
+
+comment "at-spi2-atk needs a toolchain w/ wchar, threads"
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
+
+comment "at-spi2-atk depends on X.org"
+       depends on BR2_USE_MMU
+       depends on !BR2_PACKAGE_XORG7
diff --git a/package/at-spi2-atk/at-spi2-atk.hash b/package/at-spi2-atk/at-spi2-atk.hash
new file mode 100644 (file)
index 0000000..77c8f68
--- /dev/null
@@ -0,0 +1,3 @@
+# locally calculated
+sha256 61891f0abae1689f6617a963105a3f1dcdab5970c4a36ded9c79a7a544b16a6e  at-spi2-atk-2.26.2.tar.xz
+sha256 c6105b34ab6829ff5c70eba234f40053215fa9f8383ced271b0e370a1923624b  COPYING
diff --git a/package/at-spi2-atk/at-spi2-atk.mk b/package/at-spi2-atk/at-spi2-atk.mk
new file mode 100644 (file)
index 0000000..4ef681b
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# at-spi2-atk
+#
+################################################################################
+
+AT_SPI2_ATK_VERSION_MAJOR = 2.26
+AT_SPI2_ATK_VERSION = $(AT_SPI2_ATK_VERSION_MAJOR).2
+AT_SPI2_ATK_SOURCE = at-spi2-atk-$(AT_SPI2_ATK_VERSION).tar.xz
+AT_SPI2_ATK_SITE =  http://ftp.gnome.org/pub/gnome/sources/at-spi2-atk/$(AT_SPI2_ATK_VERSION_MAJOR)
+AT_SPI2_ATK_LICENSE = LGPL-2.0+
+AT_SPI2_ATK_LICENSE_FILES = COPYING
+AT_SPI2_ATK_INSTALL_STAGING = YES
+AT_SPI2_ATK_DEPENDENCIES = atk at-spi2-core libglib2 host-pkgconf
+
+$(eval $(autotools-package))