package/libfreeimage: fix build with gcc 11
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 1 Aug 2021 12:19:36 +0000 (14:19 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 1 Aug 2021 18:47:05 +0000 (20:47 +0200)
Fix the following build failure with gcc 11:

In file included from Source/FreeImage/../OpenEXR/IlmImf/ImfHeader.h:51,
                 from Source/FreeImage/../OpenEXR/IlmImf/ImfOutputFile.h:46,
                 from Source/FreeImage/PluginEXR.cpp:33:
Source/OpenEXR/Imath/ImathVec.h:228:41: error: ISO C++17 does not allow dynamic exception specifications
  228 |     const Vec2 &        normalizeExc () throw (IEX_NAMESPACE::MathExc);
      |                                         ^~~~~

Fixes:
 - http://autobuild.buildroot.org/results/953cd07402fe2f99f2361a3b4a7b086a88e0d72d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libfreeimage/libfreeimage.mk

index 91299084a1856509447b9181f54521b52571215f..4775f92109ab873a6795684b16a2a44d7f7d6fd6 100644 (file)
@@ -20,7 +20,8 @@ define LIBFREEIMAGE_EXTRACT_CMDS
 endef
 
 define LIBFREEIMAGE_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) \
+               CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11" $(MAKE) -C $(@D)
 endef
 
 define LIBFREEIMAGE_INSTALL_STAGING_CMDS