linux-firmware: add new config option of iwlwifi 5000 firmware
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 28 Jan 2013 09:19:45 +0000 (09:19 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 28 Jan 2013 19:58:18 +0000 (20:58 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/linux-firmware/Config.in
package/linux-firmware/linux-firmware.mk

index bf264ebb748c36d52580463e1ff339db52beb237..9998f226679d706ab97952a49c7a8c6be86e8892 100644 (file)
@@ -20,6 +20,12 @@ config BR2_PACKAGE_LINUX_FIRMWARE_ATHEROS_9271
        help
          Firmware files for the Atheros 9271 module
 
+config BR2_PACKAGE_LINUX_FIRMWARE_IWLWIFI_5000
+       bool "Intel iwlwifi 5000"
+       help
+         Firmware files for the Intel Wifi 5000 devices supported by
+         the iwlwifi kernel driver.
+
 config BR2_PACKAGE_LINUX_FIRMWARE_LIBERTAS_SD8686_V8
        bool "Libertas SD 8686 v8"
        help
index db20d338dec5e11b585459fe03e9983e7a34fd20..8f9645298dffd1a4a205c225534f6942d2c6e379 100644 (file)
@@ -92,6 +92,13 @@ LINUX_FIRMWARE_FILES_$(BR2_PACKAGE_LINUX_FIRMWARE_TI_WL128X) += \
        ti-connectivity/TIInit_7.2.31.bts                       \
        LICENCE.ti-connectivity
 
+# iwlwifi 5000. Multiple files are available (iwlwifi-5000-1.ucode,
+# iwlwifi-5000-2.ucode, iwlwifi-5000-5.ucode), corresponding to
+# different versions of the firmware API. For now, we only install the
+# most recent one.
+LINUX_FIRMWARE_FILES_$(BR2_PACKAGE_LINUX_FIRMWARE_IWLWIFI_5000) += \
+       iwlwifi-5000-5.ucode LICENCE.iwlwifi_firmware
+
 LINUX_FIRMWARE_FILES_$(BR2_PACKAGE_LINUX_FIRMWARE_XC5000) += \
        dvb-fe-xc5000-1.6.114.fw