package/lua-zlib: new package
authorFrancois Perrad <fperrad@gmail.com>
Sun, 13 Jun 2021 15:42:39 +0000 (17:42 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 14 Jun 2021 20:31:32 +0000 (22:31 +0200)
This module is only partially compatible with lzlib (which is no longer
maintained).

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
[yann.morin.1998@free.fr: amend commit log about limited compatibility]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/Config.in
package/lua-zlib/Config.in [new file with mode: 0644]
package/lua-zlib/lua-zlib.hash [new file with mode: 0644]
package/lua-zlib/lua-zlib.mk [new file with mode: 0644]
support/testing/tests/package/test_lua_zlib.py [new file with mode: 0644]

index e42f579494973cf536340b85b57170d5e4c60084..388f8c1f058c3d1a9084df76d0cbd3077335085b 100644 (file)
@@ -693,6 +693,7 @@ menu "Lua libraries/modules"
        source "package/lua-testmore/Config.in"
        source "package/lua-utf8/Config.in"
        source "package/lua-valua/Config.in"
+       source "package/lua-zlib/Config.in"
        source "package/luabitop/Config.in"
        source "package/luadbi/Config.in"
        source "package/luadbi-sqlite3/Config.in"
diff --git a/package/lua-zlib/Config.in b/package/lua-zlib/Config.in
new file mode 100644 (file)
index 0000000..ffdb4a8
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LUA_ZLIB
+       bool "lua-zlib"
+       select BR2_PACKAGE_ZLIB
+       help
+         Simple streaming interface to zlib for Lua.
+         Consists of two functions: inflate and deflate.
+         Both functions return "stream functions" (takes a buffer
+         of input and returns a buffer of output).
+
+         https://github.com/brimworks/lua-zlib
diff --git a/package/lua-zlib/lua-zlib.hash b/package/lua-zlib/lua-zlib.hash
new file mode 100644 (file)
index 0000000..8c108b3
--- /dev/null
@@ -0,0 +1,2 @@
+# computed by luarocks/buildroot
+sha256 42436ba2b78c9a2d515d6da59ceb12cdea7f84c9ce3c859d91addb42badd4061  lua-zlib-1.2-0.src.rock
diff --git a/package/lua-zlib/lua-zlib.mk b/package/lua-zlib/lua-zlib.mk
new file mode 100644 (file)
index 0000000..23e2a8a
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+#
+# lua-zlib
+#
+################################################################################
+
+LUA_ZLIB_VERSION = 1.2-0
+LUA_ZLIB_SUBDIR = lua-zlib
+LUA_ZLIB_LICENSE = MIT
+LUA_ZLIB_DEPENDENCIES = zlib
+
+$(eval $(luarocks-package))
diff --git a/support/testing/tests/package/test_lua_zlib.py b/support/testing/tests/package/test_lua_zlib.py
new file mode 100644 (file)
index 0000000..6089daa
--- /dev/null
@@ -0,0 +1,25 @@
+from tests.package.test_lua import TestLuaBase
+
+
+class TestLuaLuazlib(TestLuaBase):
+    config = TestLuaBase.config + \
+        """
+        BR2_PACKAGE_LUA=y
+        BR2_PACKAGE_LUA_ZLIB=y
+        """
+
+    def test_run(self):
+        self.login()
+        self.module_test("zlib")
+
+
+class TestLuajitLuazlib(TestLuaBase):
+    config = TestLuaBase.config + \
+        """
+        BR2_PACKAGE_LUAJIT=y
+        BR2_PACKAGE_LUA_ZLIB=y
+        """
+
+    def test_run(self):
+        self.login()
+        self.module_test("zlib")