dtc: do not build/install python support
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 28 Jul 2018 13:33:51 +0000 (15:33 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 28 Jul 2018 13:33:51 +0000 (15:33 +0200)
The pylibfdt in dtc is new since 1.4.5, and therefore built since the
bump from 1.4.4 to 1.4.7 in commit
7b929ddcf0812310d0113cf3675429dbd123aa99. Unfortunately, this Python
support causes a number of build failures, be it for host-dtc or dtc.

Since this Python support is not used/needed by anything in Buildroot
at this point, let's simply disable it by passing NO_PYTHON=1. While
doing this, introduce DTC_MAKE_OPTS and HOST_DTC_MAKE_OPTS to avoid
duplicating the variables several times.

Fixes:

  http://autobuild.buildroot.net/results/1ad41fd4890af0c97ee4ff2994ea5431b8953ef8/ (host-dtc)
  http://autobuild.buildroot.net/results/0aefc3aa03a93b1fdf76f2d8946b6f423405382f/ (dtc)

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/dtc/dtc.mk

index 8388793c01f51a7e4c627166850f2c1ed533cab1..7cb879bff48b6d0622bac64a1f67ef41c5b38197 100644 (file)
@@ -13,6 +13,14 @@ DTC_INSTALL_STAGING = YES
 DTC_DEPENDENCIES = host-bison host-flex
 HOST_DTC_DEPENDENCIES = host-bison host-flex
 
+DTC_MAKE_OPTS = \
+       PREFIX=/usr \
+       NO_PYTHON=1
+
+HOST_DTC_MAKE_OPTS = \
+       PREFIX=$(HOST_DIR) \
+       NO_PYTHON=1
+
 define DTC_POST_INSTALL_TARGET_RM_DTDIFF
        rm -f $(TARGET_DIR)/usr/bin/dtdiff
 endef
@@ -32,26 +40,26 @@ DTC_INSTALL_GOAL = install-lib
 endif # $(BR2_PACKAGE_DTC_PROGRAMS) != y
 
 define DTC_BUILD_CMDS
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) CFLAGS="$(TARGET_CFLAGS) -fPIC" -C $(@D) PREFIX=/usr
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) CFLAGS="$(TARGET_CFLAGS) -fPIC" -C $(@D) $(DTC_MAKE_OPTS)
 endef
 
 # For staging, only the library is needed
 define DTC_INSTALL_STAGING_CMDS
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) PREFIX=/usr install-lib \
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) $(DTC_MAKE_OPTS) install-lib \
                install-includes
 endef
 
 define DTC_INSTALL_TARGET_CMDS
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) PREFIX=/usr $(DTC_INSTALL_GOAL)
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) $(DTC_MAKE_OPTS) $(DTC_INSTALL_GOAL)
 endef
 
 # host build
 define HOST_DTC_BUILD_CMDS
-       $(HOST_CONFIGURE_OPTS) $(MAKE) CFLAGS="$(HOST_CFLAGS) -fPIC" -C $(@D) PREFIX=$(HOST_DIR)
+       $(HOST_CONFIGURE_OPTS) $(MAKE) CFLAGS="$(HOST_CFLAGS) -fPIC" -C $(@D) $(HOST_DTC_MAKE_OPTS)
 endef
 
 define HOST_DTC_INSTALL_CMDS
-       $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) PREFIX=$(HOST_DIR) install
+       $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) $(HOST_DTC_MAKE_OPTS) install
 endef
 
 $(eval $(generic-package))