toolchain-external: download/show external toolchain with make source/external-deps
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 13 Jul 2011 06:49:52 +0000 (08:49 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 13 Jul 2011 06:50:46 +0000 (08:50 +0200)
Based on patch by HervĂ© Fache <h-fache@ti.com>.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/ext-tool.mk

index db9365b1adf0290bc62834d3154a28699a325e74..fd9a53057e87ecf57c393d64bbbe493e93ee0acd 100644 (file)
@@ -50,8 +50,6 @@
 #  $(HOST_DIR)/usr/bin like for the internal toolchains, and the rest
 #  of Buildroot is handled identical for the 2 toolchain types.
 
-uclibc: dependencies $(HOST_DIR)/usr/bin/ext-toolchain-wrapper
-
 LIB_EXTERNAL_LIBS=ld*.so libc.so libcrypt.so libdl.so libgcc_s.so libm.so libnsl.so libresolv.so librt.so libutil.so
 ifeq ($(BR2_TOOLCHAIN_EXTERNAL_GLIBC),y)
 LIB_EXTERNAL_LIBS+=libnss_files.so libnss_dns.so
@@ -197,6 +195,7 @@ TOOLCHAIN_EXTERNAL_SITE_1   = http://blackfin.uclinux.org/gf/download/frsrelease
 TOOLCHAIN_EXTERNAL_SOURCE_1 = blackfin-toolchain-2010R1-RC4.i386.tar.bz2
 TOOLCHAIN_EXTERNAL_SITE_2   = http://blackfin.uclinux.org/gf/download/frsrelease/501/8386/
 TOOLCHAIN_EXTERNAL_SOURCE_2 = blackfin-toolchain-uclibc-full-2010R1-RC4.i386.tar.bz2
+TOOLCHAIN_EXTERNAL_SOURCE   = $(TOOLCHAIN_EXTERNAL_SOURCE_1) $(TOOLCHAIN_EXTERNAL_SOURCE_2)
 else
 # A value must be set (even if unused), otherwise the
 # $(DL_DIR)/$(TOOLCHAIN_EXTERNAL_SOURCE) rule would override the main
@@ -320,3 +319,11 @@ $(HOST_DIR)/usr/bin/ext-toolchain-wrapper: $(STAMP_DIR)/ext-toolchain-installed
        done ;
        $(HOSTCC) $(HOST_CFLAGS) $(TOOLCHAIN_EXTERNAL_WRAPPER_ARGS) -s \
                toolchain/toolchain-external/ext-toolchain-wrapper.c -o $@
+
+# 'uclibc' is the target to provide toolchain / staging dir
+uclibc: dependencies $(HOST_DIR)/usr/bin/ext-toolchain-wrapper
+
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_DOWNLOAD),y)
+# download ext toolchain if so configured
+uclibc-source: $(addprefix $(DL_DIR)/,$(TOOLCHAIN_EXTERNAL_SOURCE))
+endif