lsof: bump to version 4.87
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 29 Jun 2014 15:05:03 +0000 (12:05 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Jun 2014 15:36:29 +0000 (17:36 +0200)
And install to /usr/bin/lsof rather than /bin/lsof otherwise we still
keep busybox lsof.

[Thomas: fix patch numbering, two patches had the 0001 sequence
number.]

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lsof/lsof-0001-makefile.patch [new file with mode: 0644]
package/lsof/lsof-0002-noportmap.patch [new file with mode: 0644]
package/lsof/lsof-0003-override-cflags.patch [new file with mode: 0644]
package/lsof/lsof-0004-remove-susvlegacy-funcs.patch [new file with mode: 0644]
package/lsof/lsof-4.85-makefile.patch [deleted file]
package/lsof/lsof-4.85-noportmap.patch [deleted file]
package/lsof/lsof-4.85-override-cflags.patch [deleted file]
package/lsof/lsof-4.85-remove-susvlegacy-funcs.patch [deleted file]
package/lsof/lsof.mk

diff --git a/package/lsof/lsof-0001-makefile.patch b/package/lsof/lsof-0001-makefile.patch
new file mode 100644 (file)
index 0000000..65b1b2e
--- /dev/null
@@ -0,0 +1,14 @@
+diff -ru lsof_4.81.orig/lsof_4.81_src/lib/Makefile.skel lsof_4.81/lsof_4.81_src/lib/Makefile.skel
+--- a/lib/Makefile.skel        2001-02-13 03:12:22.000000000 +0100
++++ b/lib/Makefile.skel        2006-11-29 13:51:44.000000000 +0100
+@@ -21,8 +21,8 @@
+ all:  ${LIB}
+ ${LIB}:       ${OBJ}
+-      ${AR}
+-      ${RANLIB}
++      ${AR} cr ${LIB} ${OBJ}
++      ${RANLIB} ${LIB}
+ clean:        FRC
+       rm -f ${LIB} ${OBJ} errs Makefile.bak a.out core
diff --git a/package/lsof/lsof-0002-noportmap.patch b/package/lsof/lsof-0002-noportmap.patch
new file mode 100644 (file)
index 0000000..984e0d8
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/print.c  2006-08-23 13:37:43.000000000 -0600
++++ b/print.c  2006-08-23 13:38:29.000000000 -0600
+@@ -148,6 +148,7 @@
+ static void
+ fill_portmap()
+ {
++#if !defined __UCLIBC__ || (defined __UCLIBC__ && defined __UCLIBC_HAS_RPC__)
+       char buf[128], *cp, *nm;
+       CLIENT *c;
+       int h, port, pr;
+@@ -266,6 +267,7 @@
+           Pth[pr][h] = pt;
+       }
+       clnt_destroy(c);
++#endif
+ }
diff --git a/package/lsof/lsof-0003-override-cflags.patch b/package/lsof/lsof-0003-override-cflags.patch
new file mode 100644 (file)
index 0000000..135e599
--- /dev/null
@@ -0,0 +1,13 @@
+--- lsof_4.84/Configure        2008-10-21 18:21:45.000000000 +0200
++++ lsof_4.84/Configure        2010-11-03 14:00:00.000000000 +0100
+@@ -5206,6 +5206,10 @@
+   cp $LSOF_MKFC ${LSOF_LIB}/$LSOF_LIBMKF
+ fi    # }
+ cat ./dialects/$LSOF_DIALECT_DIR/$LSOF_REST >> $LSOF_MKFC
++if test "X$LSOF_CFLAGS_OVERRIDE" != "X"       # {
++then
++  sed -i -e 's/^CFLAGS=/override CFLAGS=/' $LSOF_MKFC
++fi    # }
+ if test "X$LSOF_LIB_NO" = "X" # {
+ then
diff --git a/package/lsof/lsof-0004-remove-susvlegacy-funcs.patch b/package/lsof/lsof-0004-remove-susvlegacy-funcs.patch
new file mode 100644 (file)
index 0000000..fca66ae
--- /dev/null
@@ -0,0 +1,12 @@
+diff -rdup lsof_4.81.orig/lsof_4.81_src/dialects/linux/machine.h lsof_4.81/lsof_4.81_src/dialects/linux/machine.h
+--- a/dialects/linux/machine.h 2007-04-24 18:20:58.000000000 +0200
++++ b/dialects/linux/machine.h 2007-05-15 12:17:03.000000000 +0200
+@@ -616,6 +616,6 @@
+  * zeromem is a macro that uses bzero or memset.
+  */
+-#define       zeromem(a, l)   bzero(a, l)
++#define       zeromem(a, l)   memset(a, 0, l)
+ #endif        /* !defined(LSOF_MACHINE_H) */
+
diff --git a/package/lsof/lsof-4.85-makefile.patch b/package/lsof/lsof-4.85-makefile.patch
deleted file mode 100644 (file)
index 65b1b2e..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ru lsof_4.81.orig/lsof_4.81_src/lib/Makefile.skel lsof_4.81/lsof_4.81_src/lib/Makefile.skel
---- a/lib/Makefile.skel        2001-02-13 03:12:22.000000000 +0100
-+++ b/lib/Makefile.skel        2006-11-29 13:51:44.000000000 +0100
-@@ -21,8 +21,8 @@
- all:  ${LIB}
- ${LIB}:       ${OBJ}
--      ${AR}
--      ${RANLIB}
-+      ${AR} cr ${LIB} ${OBJ}
-+      ${RANLIB} ${LIB}
- clean:        FRC
-       rm -f ${LIB} ${OBJ} errs Makefile.bak a.out core
diff --git a/package/lsof/lsof-4.85-noportmap.patch b/package/lsof/lsof-4.85-noportmap.patch
deleted file mode 100644 (file)
index 984e0d8..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/print.c  2006-08-23 13:37:43.000000000 -0600
-+++ b/print.c  2006-08-23 13:38:29.000000000 -0600
-@@ -148,6 +148,7 @@
- static void
- fill_portmap()
- {
-+#if !defined __UCLIBC__ || (defined __UCLIBC__ && defined __UCLIBC_HAS_RPC__)
-       char buf[128], *cp, *nm;
-       CLIENT *c;
-       int h, port, pr;
-@@ -266,6 +267,7 @@
-           Pth[pr][h] = pt;
-       }
-       clnt_destroy(c);
-+#endif
- }
diff --git a/package/lsof/lsof-4.85-override-cflags.patch b/package/lsof/lsof-4.85-override-cflags.patch
deleted file mode 100644 (file)
index 135e599..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- lsof_4.84/Configure        2008-10-21 18:21:45.000000000 +0200
-+++ lsof_4.84/Configure        2010-11-03 14:00:00.000000000 +0100
-@@ -5206,6 +5206,10 @@
-   cp $LSOF_MKFC ${LSOF_LIB}/$LSOF_LIBMKF
- fi    # }
- cat ./dialects/$LSOF_DIALECT_DIR/$LSOF_REST >> $LSOF_MKFC
-+if test "X$LSOF_CFLAGS_OVERRIDE" != "X"       # {
-+then
-+  sed -i -e 's/^CFLAGS=/override CFLAGS=/' $LSOF_MKFC
-+fi    # }
- if test "X$LSOF_LIB_NO" = "X" # {
- then
diff --git a/package/lsof/lsof-4.85-remove-susvlegacy-funcs.patch b/package/lsof/lsof-4.85-remove-susvlegacy-funcs.patch
deleted file mode 100644 (file)
index fca66ae..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rdup lsof_4.81.orig/lsof_4.81_src/dialects/linux/machine.h lsof_4.81/lsof_4.81_src/dialects/linux/machine.h
---- a/dialects/linux/machine.h 2007-04-24 18:20:58.000000000 +0200
-+++ b/dialects/linux/machine.h 2007-05-15 12:17:03.000000000 +0200
-@@ -616,6 +616,6 @@
-  * zeromem is a macro that uses bzero or memset.
-  */
--#define       zeromem(a, l)   bzero(a, l)
-+#define       zeromem(a, l)   memset(a, 0, l)
- #endif        /* !defined(LSOF_MACHINE_H) */
-
index dcdb7cf5feb9f8dc83adbbd3028a73a5072d63c9..285bd476963c9caea7e594bd11179041a93f92c3 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LSOF_VERSION = 4.85
+LSOF_VERSION = 4.87
 LSOF_SOURCE = lsof_$(LSOF_VERSION).tar.bz2
 LSOF_SITE = ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/
 LSOF_LICENSE = lsof license
@@ -58,7 +58,7 @@ define LSOF_BUILD_CMDS
 endef
 
 define LSOF_INSTALL_TARGET_CMDS
-       $(INSTALL) -D -m 755 $(@D)/lsof $(TARGET_DIR)/bin/lsof
+       $(INSTALL) -D -m 755 $(@D)/lsof $(TARGET_DIR)/usr/bin/lsof
 endef
 
 $(eval $(generic-package))