system: provide no default for custom skeleton path
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 17 Jul 2016 08:44:25 +0000 (10:44 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 18 Jul 2016 21:40:06 +0000 (23:40 +0200)
Being custom means that our default one is not suitable to start with.
So there is no reason to offer it as the default path.

Add a check that it is not empty.

Add a separating empty line, for good measure, too.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Romain Naour <romain.naour@openwide.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/skeleton/skeleton.mk
system/Config.in

index 7a7c200f76be7d28354a3b548dafdf228c803338..d580fcbfff51731c9c117582112190b76c06be5d 100644 (file)
@@ -17,6 +17,12 @@ ifeq ($(BR2_ROOTFS_SKELETON_CUSTOM),y)
 
 SKELETON_PATH = $(call qstrip,$(BR2_ROOTFS_SKELETON_CUSTOM_PATH))
 
+ifeq ($(BR_BUILDING),y)
+ifeq ($(SKELETON_PATH),)
+$(error No path specified for the custom skeleton)
+endif
+endif
+
 ifeq ($(BR2_ROOTFS_MERGED_USR),y)
 
 # Ensure the user has prepared a merged /usr.
index b895db90140c1d22f10666566d12d3a78a3bc4b4..6fce8e173e8da6dba997a3d1a441187df38959b2 100644 (file)
@@ -184,9 +184,9 @@ config BR2_ROOTFS_SKELETON_CUSTOM
 endchoice
 
 if BR2_ROOTFS_SKELETON_CUSTOM
+
 config BR2_ROOTFS_SKELETON_CUSTOM_PATH
        string "custom target skeleton path"
-       default "system/skeleton"
        help
          Path to custom target skeleton.