package/vlc: add optional dependency to samba4
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:18 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 10:00:30 +0000 (12:00 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index ecc5c6cafe1f252a4ff3616692bf4b956163a87b..14fe3b7861196bdfca86b858bfc186d63eb62c2c 100644 (file)
@@ -387,6 +387,13 @@ else
 VLC_CONF_OPTS += --disable-sdl-image
 endif
 
+ifeq ($(BR2_PACKAGE_SAMBA4),y)
+VLC_CONF_OPTS += --enable-smbclient
+VLC_DEPENDENCIES += samba4
+else
+VLC_CONF_OPTS += --disable-smbclient
+endif
+
 ifeq ($(BR2_PACKAGE_SPEEX)$(BR2_PACKAGE_SPEEXDSP),yy)
 VLC_CONF_OPTS += --enable-speex
 VLC_DEPENDENCIES += speex speexdsp