libusb: add an option to compile examples
authorGaël PORTAY <gael.portay@savoirfairelinux.com>
Mon, 11 Jun 2018 13:47:50 +0000 (09:47 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Jun 2018 13:07:52 +0000 (15:07 +0200)
Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
[Thomas:
 - use make loop instead of shell loop
 - use $(INSTALL) instead of cp.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libusb/Config.in
package/libusb/libusb.mk

index 5238588aa8b947ed42965865f3cd299f5ef885db..d31a717fdfddeeac2d357f18c17f2ab500d36d66 100644 (file)
@@ -6,5 +6,12 @@ config BR2_PACKAGE_LIBUSB
 
          http://libusb.info/
 
+if BR2_PACKAGE_LIBUSB
+
+config BR2_PACKAGE_LIBUSB_EXAMPLES
+       bool "build libusb examples"
+
+endif
+
 comment "libusb needs a toolchain w/ threads"
        depends on !BR2_TOOLCHAIN_HAS_THREADS
index aee3622f8d8f55de5b47c809350b52d0bfe5d1d7..fe38a1d2d2c44c7c054fc6feb9d8229e07bb57cb 100644 (file)
@@ -25,5 +25,15 @@ else
 LIBUSB_CONF_OPTS += --disable-udev
 endif
 
+ifeq ($(BR2_PACKAGE_LIBUSB_EXAMPLES),y)
+LIBUSB_CONF_OPTS += --enable-examples-build
+define LIBUSB_INSTALL_TARGET_EXAMPLES
+       $(foreach example,listdevs xusb fxload hotplugtest testlibusb dpfp dpfp_threaded sam3u_benchmark,
+               $(INSTALL) -D -m0755 $(@D)/examples/$(example) $(TARGET_DIR)/usr/bin/$(example)
+       )
+endef
+LIBUSB_POST_INSTALL_TARGET_HOOKS += LIBUSB_INSTALL_TARGET_EXAMPLES
+endif
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))