gitlab-ci: run check-package
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 29 Nov 2017 23:08:45 +0000 (00:08 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Dec 2017 22:00:02 +0000 (23:00 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
.gitlab-ci.yml
.gitlab-ci.yml.in

index c34d2f7b1cb4fcdeef818833536bcb5020335353..a6540d1fda33799ec447869d7756078038eb1a76 100644 (file)
@@ -30,6 +30,10 @@ check-DEVELOPERS:
     script:
         - "! utils/get-developers | grep -v 'No action specified'"
 
+check-package:
+    script:
+        - find . -type f -name '*.mk' -exec ./utils/check-package {} +
+
 .defconfig: &defconfig
     # Running the defconfigs for every push is too much, so limit to
     # explicit triggers through the API.
index 33c7b13725235ced7471418d95444700a5718a18..0d2e239414e7a48dfb2f166117a18862d42c9e84 100644 (file)
@@ -30,6 +30,10 @@ check-DEVELOPERS:
     script:
         - "! utils/get-developers | grep -v 'No action specified'"
 
+check-package:
+    script:
+        - find . -type f -name '*.mk' -exec ./utils/check-package {} +
+
 .defconfig: &defconfig
     # Running the defconfigs for every push is too much, so limit to
     # explicit triggers through the API.