package/linux-firmware: install Xceive/Cresta xc4000 and xc5000c
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 21 Sep 2014 18:38:13 +0000 (20:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Sep 2014 19:15:03 +0000 (21:15 +0200)
Tweak the prompt, because Xceive is now part of Cresta, so the
new xc5000c-based devices might be branded under either name.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/linux-firmware/Config.in
package/linux-firmware/linux-firmware.mk

index e233e3c648f6e7373c80e21fa472b5b9f448839f..6e202fe1d513a4467994d1e2723a7d1cd5b3a5a6 100644 (file)
@@ -101,6 +101,14 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2014.11"
 
+config BR2_PACKAGE_LINUX_FIRMWARE_XC5000
+       bool "Xceive xc5000 option has been renamed"
+       select BR2_PACKAGE_LINUX_FIRMWARE_XCx000
+       help
+         The Xceive xc5000 option now also handles older firmwares from
+         Xceive (the xc4000 series), as well as new firmwares (the xc5000c)
+         from Cresta, who bought Xceive.
+
 config BR2_PACKAGE_LINUX_FIRMWARE_CXGB4
        bool "Chelsio T4 option has been renamed"
        select BR2_PACKAGE_LINUX_FIRMWARE_CXGB4_T4
index 9d39df8941ea2232f43daea57ee14c31cdec989f..cd35dcccbf3c6e28b7ed9dcbe139e9d9b009121a 100644 (file)
@@ -217,10 +217,10 @@ config BR2_PACKAGE_LINUX_FIRMWARE_H5_DRXK
        help
          Firmware file for Terratec H5 DRX-K based DVB tuner driver
 
-config BR2_PACKAGE_LINUX_FIRMWARE_XC5000
-       bool "Xceive xc5000"
+config BR2_PACKAGE_LINUX_FIRMWARE_XCx000
+       bool "Xceive/Cresta xc4000/xc5000/xc500c"
        help
-         Firmware file for xc5000-based DVB tuner driver
+         Firmware file for xc4000/xc5000/xc5000c based DVB tuner driver
 
 endmenu
 
index bc036be4cfc46278322dd184756f1a0e5fe2cd7e..43039851efb8d2040fa227ea463744f4aa76468e 100644 (file)
@@ -203,9 +203,13 @@ LINUX_FIRMWARE_FILES += cxgb4/t5fw-1.11.27.0.bin cxgb4/t5fw.bin
 LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.chelsio_firmware
 endif
 
-ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_XC5000),y)
-LINUX_FIRMWARE_FILES += dvb-fe-xc5000-1.6.114.fw
-LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.xc5000
+ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_XCx000),y)
+LINUX_FIRMWARE_FILES += dvb-fe-xc4000-1.4.1.fw \
+                       dvb-fe-xc5000-1.6.114.fw \
+                       dvb-fe-xc5000c-4.1.30.7.fw
+LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.xc4000 \
+                                   LICENCE.xc5000 \
+                                   LICENCE.xc5000c
 endif
 
 ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_AS102),y)