package/binutils: fix build error due to architecture name is incomplete
authorNylon Chen <nylon7@andestech.com>
Thu, 18 Apr 2019 09:46:55 +0000 (17:46 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 20 Apr 2019 14:16:39 +0000 (16:16 +0200)
Fixes
  http://autobuild.buildroot.net/results/128/12803a705586e82fdfb49013da2eb3b9879ccd45/

Signed-off-by: Che-Wei Chuang <cnoize@andestech.com>
Signed-off-by: Greentime Hu <greentime@andestech.com>
Signed-off-by: Nylon Chen <nylon7@andestech.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Makefile
arch/Config.in.nds32
package/binutils/Config.in

index 522c0b0606cd2b50d8aa45e0e5d1f3fea7856124..86e444da989d0a694e39d2567d8ee459d14c7c12 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -439,6 +439,7 @@ KERNEL_ARCH := $(shell echo "$(ARCH)" | sed -e "s/-.*//" \
        -e s/arceb/arc/ \
        -e s/arm.*/arm/ -e s/sa110/arm/ \
        -e s/aarch64.*/arm64/ \
+       -e s/nds32.*/nds32/ \
        -e s/or1k/openrisc/ \
        -e s/parisc64/parisc/ \
        -e s/powerpc64.*/powerpc/ \
index 9c5db20e6fda78c986654752f041f85a8a49ccc3..f268883662f8a64fcd8ba51e11378e7e0a4382c4 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_ARCH
-       default "nds32"
+       default "nds32le"
 
 config BR2_GCC_TARGET_ARCH
        default "v3"
index 2bf7929ac84eb9e230c5bad298689992668fd203..e17a8ec65acabad084525b96ea4d1a285aebbbea 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_BINUTILS
        bool "binutils"
-       depends on !BR2_nios2 && !BR2_nds32
+       depends on !BR2_nios2
        depends on BR2_USE_WCHAR
        help
          Install binutils on the target
@@ -21,5 +21,5 @@ config BR2_PACKAGE_BINUTILS_TARGET
 endif
 
 comment "binutils needs a toolchain w/ wchar"
-       depends on !BR2_nios2 && !BR2_nds32
+       depends on !BR2_nios2
        depends on !BR2_USE_WCHAR